# CVE-2026-59203: Pillow EpsImagePlugin negative %%BeginBinary byte count causes infinite loop denial of service

> A crafted EPS file with a negative byte count causes an infinite loop in Pillow's parser, leading to denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-pillow-2026-59203, DEBIAN-CVE-2026-59203, ECHO-9f30-2662-0f87, GHSA-pg7v-jwj7-p798, MINI-24v6-5w5r-gp9w, MINI-33p8-x982-5jxx, MINI-3482-jg8q-xr97, MINI-3w9c-578q-hjhw, MINI-5cgp-fqxf-mq6h, MINI-7p5f-5hqm-j843, MINI-fjh7-2xh5-2m3h, MINI-jm8c-v29p-5f25, MINI-qvj8-ww4h-g9w2, MINI-v27w-9r5v-3976, PYSEC-2026-3452, ROOT-APP-PYPI-CVE-2026-59203, UBUNTU-CVE-2026-59203

## What is CVE-2026-59203?

CVE-2026-59203 is a medium-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. From 12.0.0 through 12.2.0, Pillow's EPS parser in PIL/EpsImagePlugin.py accepts a negative byte count in the %%BeginBinary directive, allowing a crafted EPS file to cause Image.open() to seek backwards to the same directive and parse it repeatedly in an infinite loop. This issue is fixed in version 12.3.0.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-59203?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 12.0.0 | 12.3.0 |
| `pillow` | PyPI | From 12.0.0 | 12.3.0 |
| `pillow` | PyPI | From 12.0.0 | 12.3.0 |
| `pillow` | PyPI | From 12.0.0 | 12.3.0 |

Products: Python Pillow.

## How do I fix CVE-2026-59203?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-59203 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59203 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59203 and fix it if it is affected.

What it is: CVE-2026-59203 is a medium-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59203 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 12.0.0; fixed in 12.3.0
- pillow (PyPI): affected from 12.0.0; fixed in 12.3.0
- pillow (PyPI): affected from 12.0.0; fixed in 12.3.0
- pillow (PyPI): affected from 12.0.0; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59203/ (Markdown: https://insights.sbomify.com/CVE-2026-59203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59203
- OSV: https://osv.dev/vulnerability/CVE-2026-59203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59203/
Summaries are generated and may contain mistakes; the official description above is the record.
