# CVE-2026-59204: Pillow JPEG2000 tiled decode retains a growing scratch buffer and can be used for denial of service

> A crafted tiled JPEG2000 image can cause excessive memory usage in Pillow, leading to out-of-memory failures and denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** BIT-pillow-2026-59204, DEBIAN-CVE-2026-59204, ECHO-4d81-9643-d9a5, GHSA-vjc4-5qp5-m44j, MINI-2347-8m6w-7q5f, MINI-23j6-fxv5-vq76, MINI-2q5f-j8pj-rgwr, MINI-47vm-g632-6w2f, MINI-5g5h-3ccc-6rvq, MINI-6c7v-h584-63hw, MINI-9j4m-3m48-cxp4, MINI-c3h7-grwp-484v, MINI-pq23-8p27-v29j, MINI-w35w-6rvw-p3xv, MINI-w4qp-5mrh-qr79, PYSEC-2026-3496, ROOT-APP-PYPI-CVE-2026-59204, UBUNTU-CVE-2026-59204

## What is CVE-2026-59204?

CVE-2026-59204 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. From 8.2.0 through 12.2.0, src/libImaging/Jpeg2KDecode.c accumulates total_component_width across every tile in a JPEG2000 image instead of recomputing it per tile, allowing a crafted tiled JPEG2000 file to force substantially higher transient memory usage and trigger out-of-memory failures during decoding. This issue is fixed in version 12.3.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-59204?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 8.2.0 | 12.3.0 |
| `pillow` | PyPI | From 8.2.0 | 12.3.0 |
| `pillow` | PyPI | From 8.2.0 | 12.3.0 |
| `pillow` | PyPI | From 8.2.0 | 12.3.0 |

Products: Python Pillow.

## How do I fix CVE-2026-59204?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-59204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59204 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59204 and fix it if it is affected.

What it is: CVE-2026-59204 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59204 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 8.2.0; fixed in 12.3.0
- pillow (PyPI): affected from 8.2.0; fixed in 12.3.0
- pillow (PyPI): affected from 8.2.0; fixed in 12.3.0
- pillow (PyPI): affected from 8.2.0; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59204/ (Markdown: https://insights.sbomify.com/CVE-2026-59204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59204
- OSV: https://osv.dev/vulnerability/CVE-2026-59204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59204/
Summaries are generated and may contain mistakes; the official description above is the record.
