CVE-2026-59207 n8n: "Allowed HTTP Request Domains" Restriction Bypass via AI Agents MCP Connector

High 7.1 Published Updated

Attackers can bypass domain restrictions in n8n AI Agents to exfiltrate credential secrets to external servers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59207?

CVE-2026-59207 is a high-severity vulnerability in N8n N8n, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n is an open source workflow automation platform. Prior to 2.27.4 and 2.28.1, the AI Agents feature did not enforce the Allowed HTTP Request Domains restriction configured on credentials when an MCP tool was pointed at an arbitrary URL, allowing a member-level user with use-only access to a shared credential to send its secret to an external server they control. This issue is fixed in versions 2.27.4 and 2.28.1.

Weakness: CWE-693

Which versions are affected by CVE-2026-59207?

4 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions2.27.4
n8n npmAll versions2.27.4
n8n npmFrom 2.28.02.28.1
n8n npmFrom 2.28.02.28.1

Products include N8n N8n.

How do I fix CVE-2026-59207?

Upgrade n8n to a fixed version for your release line: 2.27.4 or 2.28.1.

Is CVE-2026-59207 being exploited?

There is no known exploitation of CVE-2026-59207 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-h44j-f5r5-ph73, MINI-pfq6-398q-v8xj, ROOT-APP-NPM-CVE-2026-59207.

Is CVE-2026-59207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free