CVE-2026-59208 n8n: Cross-Issuer Token Exchange Account Binding via Subject-Only Identity Resolution
Attackers can authenticate as victims by exploiting subject-only identity resolution in multi-issuer token exchange configurations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59208?
CVE-2026-59208 is a high-severity authentication bypass vulnerability in N8n N8n, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 2.27.4 and from 2.28.0 prior to 2.28.1, n8n instances configured with more than one trusted token-exchange issuer resolved external identities to local accounts using only the JWT sub claim and ignored the iss claim, allowing an attacker with a valid token from one trusted issuer and a sub matching a victim under another issuer to authenticate as that victim. This issue is fixed in versions 2.27.4 and 2.28.1.
Which versions are affected by CVE-2026-59208?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.27.4 |
n8n npm | All versions | 2.27.4 |
n8n npm | From 2.28.0 | 2.28.1 |
n8n npm | From 2.28.0 | 2.28.1 |
Products include N8n N8n.
How do I fix CVE-2026-59208?
Upgrade n8n to a fixed version for your release line: 2.27.4 or 2.28.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-59208 being exploited?
There is no known exploitation of CVE-2026-59208 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-mq3m-f8x3-579w, MINI-p629-g5hm-f7w4, ROOT-APP-NPM-CVE-2026-59208.