CVE-2026-59209 n8n: Shared Credential Header Leak via HTTP Request Pagination Expression
An authenticated user with limited access can read and exfiltrate sensitive credential headers from shared workflows via HTTP request pagination expressions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59209?
CVE-2026-59209 is a high-severity vulnerability in N8n N8n, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.61, 2.27.4, and, 2.28.1, an authenticated member with use-only editor access to a shared workflow could read credential-populated headers exposed via the $request object inside an HTTP Request node's pagination expression and exfiltrate the secret through item data. This issue is fixed in versions 1.123.61, 2.27.4, and 2.28.1.
Which versions are affected by CVE-2026-59209?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.61 |
n8n npm | All versions | 1.123.61 |
n8n npm | From 2.0.0-rc.0 | 2.27.4 |
n8n npm | From 2.0.0-rc.0 | 2.27.4 |
n8n npm | From 2.28.0 | 2.28.1 |
n8n npm | From 2.28.0 | 2.28.1 |
Products include N8n N8n.
How do I fix CVE-2026-59209?
Upgrade n8n to a fixed version for your release line: 1.123.61, 2.27.4 or 2.28.1.
Is CVE-2026-59209 being exploited?
There is no known exploitation of CVE-2026-59209 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-q3j5-8vrg-4p9q, MINI-qg4m-6px8-6jg8, ROOT-APP-NPM-CVE-2026-59209.