# CVE-2026-59216: Open WebUI: Cross-user code-interpreter and tool execution via unvalidated Socket.IO event-caller session_id

> Authenticated users can execute Python code or tools in other users' sessions by exploiting unvalidated Socket.IO session IDs, leading to cross-user code execution.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-74h3-cxq7-vc5q, PYSEC-2026-3592

## What is CVE-2026-59216?

CVE-2026-59216 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. Prior to 0.10.0, get_event_call delivered execute:python and execute:tool Socket.IO events to a client-supplied session_id after checking only that the session was connected, allowing authenticated users who learned another socket ID through ydoc:document:join to run code interpreter Python or tools in that user session. This issue is fixed in version 0.10.0.

Weakness: CWE-862 (Missing Authorization), CWE-94 (Improper Control of Generation of Code), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-59216?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.10.0 |
| `open-webui` | PyPI | All versions | 0.10.0 |
| `open-webui` | PyPI | All versions | 0.10.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-59216?

Upgrade open-webui to 0.10.0 or later.

## Is CVE-2026-59216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59216 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59216 and fix it if it is affected.

What it is: CVE-2026-59216 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59216 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.10.0
- open-webui (PyPI): affected all versions; fixed in 0.10.0
- open-webui (PyPI): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59216/ (Markdown: https://insights.sbomify.com/CVE-2026-59216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59216
- OSV: https://osv.dev/vulnerability/CVE-2026-59216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59216/
Summaries are generated and may contain mistakes; the official description above is the record.
