# CVE-2026-59222: Open WebUI: /api/v1/channels/{id}/members exposes full user model including sensitive credentials

> A normal channel participant can retrieve other users' sensitive settings and credentials via the members API endpoint.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-gh7p-78x6-jw6m, PYSEC-2026-3598

## What is CVE-2026-59222?

CVE-2026-59222 is a medium-severity vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.7.0 before 0.10.0, GET /api/v1/channels//members returned full UserModelResponse objects for channel members, including settings.ui.toolServers[].key and webhook configuration, allowing a normal channel participant to retrieve other users’ sensitive settings. This issue is fixed in version 0.10.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-59222?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.7.0 | 0.10.0 |
| `open-webui` | PyPI | From 0.7.0 | 0.10.0 |
| `open-webui` | PyPI | From 0.7.0 | 0.10.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-59222?

Upgrade open-webui to 0.10.0 or later.

## Is CVE-2026-59222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59222 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59222 and fix it if it is affected.

What it is: CVE-2026-59222 is a medium-severity vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59222 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.7.0; fixed in 0.10.0
- open-webui (PyPI): affected from 0.7.0; fixed in 0.10.0
- open-webui (PyPI): affected from 0.7.0; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59222/ (Markdown: https://insights.sbomify.com/CVE-2026-59222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59222
- OSV: https://osv.dev/vulnerability/CVE-2026-59222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59222/
Summaries are generated and may contain mistakes; the official description above is the record.
