{"answers":{"affected":"3 open source packages ship an affected version, including open-webui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59227 exists.","fix":"Upgrade open-webui to 0.10.0 or later.","what":"CVE-2026-59227 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59227 and fix it if it is affected.\n\nWhat it is: CVE-2026-59227 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59227 exists.\n\nAffected packages and fixed versions:\n- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0\n- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0\n- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59227/ (Markdown: https://insights.sbomify.com/CVE-2026-59227/index.md)","id":"CVE-2026-59227","markdown":"https://insights.sbomify.com/CVE-2026-59227/index.md","name":"CVE-2026-59227","record":{"aliases":["GHSA-rqj7-6wrp-6g2g","PYSEC-2026-3604"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Open WebUI AI platform","requires_auth":"low_privilege","summary":"Non-admin users can bypass image-editing restrictions to invoke server-side image editing using administrator-configured provider credentials.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_webui","vendor":"openwebui"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-862","name":"Missing Authorization"}],"description":"Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.8.11 before 0.10.0, POST /api/v1/images/edit required only a verified account and did not enforce the global image-edit switch or the per-user image-generation permission, allowing a non-admin user to invoke server-side image editing with administrator-configured provider credentials. This issue is fixed in version 0.10.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Open WebUI: POST /api/v1/images/edit bypasses the global image-edit switch and the per-user image-generation permission","id":"CVE-2026-59227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"openwebui:open_webui","products":["openwebui:open_webui"],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Apache IoTDB: Legacy Pipe Privilege Escalation","id":"CVE-2026-59229"},"packages":[{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0.8.11"],"last_affected":[],"package":"open-webui","purl":null,"source":"GHSA-rqj7-6wrp-6g2g"},{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0.8.11"],"last_affected":[],"package":"open-webui","purl":"pkg:pypi/open-webui","source":"GHSA-rqj7-6wrp-6g2g"},{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0.8.11"],"last_affected":[],"package":"open-webui","purl":"pkg:pypi/open-webui","source":"PYSEC-2026-3604"}],"prev":{"headline":"Open WebUI: Scheduled automations continue after pending-user deactivation and stored model ACL revocation","id":"CVE-2026-59226"},"products":["open-webui"],"published":"2026-07-09","related":[{"cvss_score":9.1,"headline":"Open WebUI: LDAP Empty Password Authentication Bypass","id":"CVE-2026-44551","kev_date_added":null,"published":"2026-05-15"},{"cvss_score":9,"headline":"open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation","id":"CVE-2026-56400","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) in open-webui/open-webui","id":"CVE-2024-8017","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":8.8,"headline":"Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed","id":"CVE-2026-45672","kev_date_added":null,"published":"2026-05-15"},{"cvss_score":8.7,"headline":"Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin","id":"CVE-2026-87995","kev_date_added":null,"published":"2026-09-09"},{"cvss_score":8.7,"headline":"Open WebUI: Stored XSS via unescaped KaTeX render-error fallback in rendered messages","id":"CVE-2026-70492","kev_date_added":null,"published":"2026-08-04"},{"cvss_score":8.7,"headline":"Open WebUI: Stored XSS in Mermaid Markdown Preview","id":"CVE-2026-54011","kev_date_added":null,"published":"2026-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["open-webui"]},"summary":"Non-admin users can bypass image-editing restrictions to invoke server-side image editing using administrator-configured provider credentials.","url":"https://insights.sbomify.com/CVE-2026-59227/"}