# CVE-2026-59227: Open WebUI: POST /api/v1/images/edit bypasses the global image-edit switch and the per-user image-generation permission

> Non-admin users can bypass image-editing restrictions to invoke server-side image editing using administrator-configured provider credentials.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-rqj7-6wrp-6g2g, PYSEC-2026-3604

## What is CVE-2026-59227?

CVE-2026-59227 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.8.11 before 0.10.0, POST /api/v1/images/edit required only a verified account and did not enforce the global image-edit switch or the per-user image-generation permission, allowing a non-admin user to invoke server-side image editing with administrator-configured provider credentials. This issue is fixed in version 0.10.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-59227?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.8.11 | 0.10.0 |
| `open-webui` | PyPI | From 0.8.11 | 0.10.0 |
| `open-webui` | PyPI | From 0.8.11 | 0.10.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-59227?

Upgrade open-webui to 0.10.0 or later.

## Is CVE-2026-59227 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59227 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59227 and fix it if it is affected.

What it is: CVE-2026-59227 is a medium-severity missing authorization vulnerability in Openwebui Open Webui, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59227 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0
- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0
- open-webui (PyPI): affected from 0.8.11; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59227/ (Markdown: https://insights.sbomify.com/CVE-2026-59227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59227
- OSV: https://osv.dev/vulnerability/CVE-2026-59227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59227/
Summaries are generated and may contain mistakes; the official description above is the record.
