# CVE-2026-59245: Privilege escalation in Apache Airflow FAB provider

> A DAG named 'DAGs' causes a resource name collision, granting users per-DAG access global permissions to all DAGs.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 16 Sep 2026
- **Also known as:** CLEANSTART-2026-KM66532, GHSA-fx25-85xr-cgxm

## What is CVE-2026-59245?

CVE-2026-59245 is a high-severity vulnerability in Apache Airflow FAB provider, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In the Apache Airflow FAB auth manager, a DAG whose `dag_id` is `DAGs` collided with the global all-DAGs permission resource name produced by `resource_name()`, so a user granted per-DAG `access_control` on that one DAG was silently granted the global all-DAGs permission (privilege escalation). The escalation triggers when a DAG named `DAGs` exists and a lower-privileged user is given per-DAG access to it, granting that user read/edit access to every DAG. Users are advised to upgrade to `apache-airflow-providers-fab` 3.7.2 or later, which disambiguates the resource-name collision.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-59245?

It affects 1 product.


Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-59245?

Upgrade to a fixed version.

## Is CVE-2026-59245 being exploited?

There is no known exploitation of CVE-2026-59245 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59245 and fix it if it is affected.

What it is: CVE-2026-59245 is a high-severity vulnerability in Apache Airflow FAB provider, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59245 in the wild and no public exploit code.

Affected product: Apache Airflow FAB provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59245/ (Markdown: https://insights.sbomify.com/CVE-2026-59245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59245
- OSV: https://osv.dev/vulnerability/CVE-2026-59245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59245/
Summaries are generated and may contain mistakes; the official description above is the record.
