{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-59247 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-59247 is a high-severity vulnerability in gleam-lang gleam, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-59247 and fix it if it is affected.\n\nWhat it is: CVE-2026-59247 is a high-severity vulnerability in gleam-lang gleam, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-59247 in the wild and no public exploit code.\n\nAffected product: gleam-lang gleam. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59247/ (Markdown: https://insights.sbomify.com/CVE-2026-59247/index.md)","id":"CVE-2026-59247","markdown":"https://insights.sbomify.com/CVE-2026-59247/index.md","name":"CVE-2026-59247","record":{"aliases":["EEF-CVE-2026-59247","GHSA-4vvc-458m-r82g","openSUSE-SU-2026:11462-1","openSUSE-SU-2026:21557-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Gleam compiler","requires_auth":"none","summary":"A man-in-the-middle attacker can substitute forged Hex package contents during dependency resolution in Gleam, leading to code execution.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Insufficient Verification of Data Authenticity vulnerability in Gleam allows an adversary in the middle to substitute forged Hex package contents during dependency resolution.\n\nDuring dependency resolution Gleam fetches package metadata from the signature-verified Hex repository, which covers each release's dependency requirements and SHA-256 outer_checksum. After resolving versions, gleam_cli::dependencies::lookup_package makes a second request to the unsigned Hex API through gleam_core::hex::get_package_release and records the outer_checksum and dependency names from that JSON response into manifest.toml, instead of the values from the verified repository metadata. The Hex repository signature does not cover the API response.\n\nAn adversary in the middle who can intercept TLS with a certificate trusted by the Gleam process (for example a TLS-inspecting proxy using a CA in the operating system trust store or added through GLEAM_CACERTS_PATH), and who can modify both the API release response and the corresponding repository tarball, can supply a package archive with a matching forged checksum without the Hex repository signing key. Gleam verifies the forged tarball against the forged checksum, accepts it, and extracts it as a dependency source, resulting in loss of integrity of the downloaded package contents.\n\nOnly projects that resolve or update Hex dependencies are affected, which happens when the manifest is missing, a dependency is added or updated, or dependency requirements change. Builds that reuse an unchanged, known-good manifest.toml continue to verify tarballs against its pinned checksum. This issue affects gleam: from 0.18.0 before 1.18.0.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient verification of Hex package metadata in Gleam","id":"CVE-2026-59247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"supply_chain","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Unbounded HPACK/QPACK prefixed-integer decoding in Cowlib causes memory-exhaustion DoS","id":"CVE-2026-59248"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.18.1-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"gleam","purl":"pkg:rpm/opensuse/gleam\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21557-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.18.1-1.1"],"introduced":["0"],"last_affected":[],"package":"gleam","purl":"pkg:rpm/opensuse/gleam\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11462-1"}],"prev":{"headline":"Zero-length HTTP/2 CONTINUATION frames bypass Mint's header-block byte-size cap and exhaust client memory","id":"CVE-2026-59246"},"products":["gleam"],"published":"2026-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["gleam-lang"]},"summary":"A man-in-the-middle attacker can substitute forged Hex package contents during dependency resolution in Gleam, leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-59247/"}