# CVE-2026-59254: n8n - External Secrets Disclosure via Workflow Node Expressions

> Authenticated project editors can read plaintext external secrets by referencing them in workflow node expressions, bypassing intended access controls.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2434-3x6q-8r99, MINI-44vv-f3j5-vh5g

## What is CVE-2026-59254?

CVE-2026-59254 is a medium-severity vulnerability in n8n, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n before 2.28.1 contains an information disclosure vulnerability where external secrets are incorrectly resolved in workflow node expressions outside credentials scope. Authenticated project editors can read plaintext external secret values by referencing them in node expressions without requiring explicit secrets access permissions.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-59254?

4 open source packages ship an affected version, including n8n.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 2.27.4 |
| `n8n` | npm | All versions | 2.27.4 |
| `n8n` | npm | From 2.28.0 | 2.28.1 |
| `n8n` | npm | From 2.28.0 | 2.28.1 |

## How do I fix CVE-2026-59254?

Upgrade n8n to a fixed version for your release line: 2.27.4 or 2.28.1.

## Is CVE-2026-59254 being exploited?

There is no known exploitation of CVE-2026-59254 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59254 and fix it if it is affected.

What it is: CVE-2026-59254 is a medium-severity vulnerability in n8n, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59254 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 2.27.4
- n8n (npm): affected all versions; fixed in 2.27.4
- n8n (npm): affected from 2.28.0; fixed in 2.28.1
- n8n (npm): affected from 2.28.0; fixed in 2.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59254/ (Markdown: https://insights.sbomify.com/CVE-2026-59254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59254
- OSV: https://osv.dev/vulnerability/CVE-2026-59254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59254/
Summaries are generated and may contain mistakes; the official description above is the record.
