CVE-2026-59259 n8n - Permission Bypass via Expression Parser Mismatch in External Secrets
Authenticated users can bypass permission checks to access external secrets via expression parser mismatches in n8n.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59259?
CVE-2026-59259 is a medium-severity missing authorization vulnerability in N8n N8n, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before versions 1.123.61, 2.27.4, and 2.28.1 contains a permission bypass vulnerability in external secrets handling caused by a mismatch between the static validation check and the runtime expression engine. An authenticated user with credential create or update permissions but without the externalSecret:list scope can embed external secret references into credentials in forms the static validation does not detect; these references resolve at workflow execution time, exposing secret values the user is not authorized to access. This issue only affects instances where an external secrets provider is configured and Advanced Permissions are in use.
Weakness: CWE-639
Which versions are affected by CVE-2026-59259?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.61 |
n8n npm | All versions | 1.123.61 |
n8n npm | From 2.0.0-rc.0 | 2.27.4 |
n8n npm | From 2.0.0-rc.0 | 2.27.4 |
n8n npm | From 2.28.0 | 2.28.1 |
n8n npm | From 2.28.0 | 2.28.1 |
Products include N8n N8n.
How do I fix CVE-2026-59259?
Upgrade n8n to a fixed version for your release line: 1.123.61, 2.27.4 or 2.28.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-59259 being exploited?
There is no known exploitation of CVE-2026-59259 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as CLEANSTART-2026-RX62233, GHSA-jp7m-xcgx-57qm, MINI-m6cj-3p2g-cpx4.