CVE-2026-59265 Apache OpenOffice, Apache OpenOffice: Opening a malicious document can lead to system takeover

High 8.8 Published Updated

Attackers can execute arbitrary code by tricking users into opening malicious documents in Apache OpenOffice.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-59265?

CVE-2026-59265 is a high-severity code injection vulnerability in Apache OpenOffice, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A code execution issue in the Java integration in Apache OpenOffice v4.1.16 and earlier allows a crafted untrusted document to trigger executing arbitrary (even remote) code when opened by the user.

This issue is expected to be fixed in version 4.1.17, which is in the release candidate phase.

Until then, users can mitigate this issue by disabling Java runtime integration in the Preferences dialog. This prevents the attack. If this is not possible, or as an extra precaution, you can avoid opening open untrusted files entirely. Once 4.1.17 is released, upgrade to that version to fix the issue.

Weakness: CWE-426

Which versions are affected by CVE-2026-59265?

How do I fix CVE-2026-59265?

No fix has been published for CVE-2026-59265 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-59265 being exploited?

There is no known exploitation of CVE-2026-59265 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-55r6-rg38-gm55.

Is CVE-2026-59265 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free