# CVE-2026-59265: Apache OpenOffice, Apache OpenOffice: Opening a malicious document can lead to system takeover

> Attackers can execute arbitrary code by tricking users into opening malicious documents in Apache OpenOffice.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-55r6-rg38-gm55

## What is CVE-2026-59265?

CVE-2026-59265 is a high-severity code injection vulnerability in Apache OpenOffice, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A code execution issue in the Java integration in Apache OpenOffice v4.1.16 and earlier allows a crafted untrusted document to trigger executing arbitrary (even remote) code when opened by the user.

This issue is expected to be fixed in version 4.1.17, which is in the release candidate phase.

Until then, users can mitigate this issue by disabling Java runtime integration in the Preferences dialog. This prevents the attack. If this is not possible, or as an extra precaution, you can avoid opening open untrusted files entirely. Once 4.1.17 is released, upgrade to that version to fix the issue.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-59265?


## How do I fix CVE-2026-59265?

No fix has been published for CVE-2026-59265 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59265 being exploited?

There is no known exploitation of CVE-2026-59265 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-59265 (github_poc): https://github.com/HORKimhab/CVE-2026-59265

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59265 and fix it if it is affected.

What it is: CVE-2026-59265 is a high-severity code injection vulnerability in Apache OpenOffice, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59265 in the wild and no public exploit code.

Affected product: Apache OpenOffice. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59265/ (Markdown: https://insights.sbomify.com/CVE-2026-59265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59265
- OSV: https://osv.dev/vulnerability/CVE-2026-59265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59265/
Summaries are generated and may contain mistakes; the official description above is the record.
