CVE-2026-5952 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Authenticated developers can bypass package protection rules to overwrite protected Maven package metadata due to incorrect authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-5952?

CVE-2026-5952 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.11 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to bypass package protection rules and overwrite protected Maven package metadata due to incorrect authorization checks.

Weakness: CWE-863

Which versions are affected by CVE-2026-5952?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.11.018.11.6, 19.0.3, 19.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-5952?

Upgrade gitlab to a fixed version for your release line: 18.11.6, 19.0.3 or 19.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-5952 being exploited?

There is no known exploitation of CVE-2026-5952 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-5952, GHSA-8vj4-48p6-q87m.

Is CVE-2026-5952 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free