CVE-2026-59654 Apache CloudStack: DoS caused by database connections leak

Medium 6.8 Published Updated

Attackers can cause denial of service in Apache CloudStack management server by exploiting a database connection leak in scoped global configuration.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-59654?

CVE-2026-59654 is a medium-severity denial of service vulnerability in Apache Cloudstack, published on 21 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Missing Release of Resource after Effective Lifetime vulnerability in Apache CloudStack's scoped global configuration functionality. It affects different modules and plugins of the CloudStack management server, including Quota, Host-HA, etc., and may lead to eventual denial of service (DoS) scenario for the management server.

This issue affects Apache CloudStack: from 4.7.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-772

Which versions are affected by CVE-2026-59654?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-59654?

No fix has been published for CVE-2026-59654 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-59654 being exploited?

There is no known exploitation of CVE-2026-59654 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-9j4g-grw7-5966.

Is CVE-2026-59654 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free