{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-59674 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-59674 is a high-severity vulnerability in openSUSE Tumbleweed, published on 14 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59674 and fix it if it is affected.\n\nWhat it is: CVE-2026-59674 is a high-severity vulnerability in openSUSE Tumbleweed, published on 14 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59674 in the wild and no public exploit code.\n\nAffected product: openSUSE Tumbleweed. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59674/ (Markdown: https://insights.sbomify.com/CVE-2026-59674/index.md)","id":"CVE-2026-59674","markdown":"https://insights.sbomify.com/CVE-2026-59674/index.md","name":"CVE-2026-59674","record":{"aliases":["GHSA-j33g-47h2-2687","openSUSE-SU-2026:11207-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE package","requires_auth":"low_privilege","summary":"The suricata user can escalate to root privileges via a symlink following vulnerability in the package installation script.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/S:N","version":"4.0"},"cwes":[{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"A UNIX Symbolic Link (Symlink) Following vulnerability in openSUSE Tumbleweed suricata package allows the suricata user to escalate to root.\n\nThis issue affects openSUSE Tumbleweed: from ? before 8.0.5-2.1; openSUSE Tumbleweed: from ? before 8.0.5-2.1.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LPE from suricata user to root due to chown in %post in suricata packaging","id":"CVE-2026-59674","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Rancher Audit-Log Middleware Unauthenticated Memory Exhaustion Denial of Service","id":"CVE-2026-59675"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.0.5-2.1"],"introduced":["0"],"last_affected":[],"package":"suricata","purl":"pkg:rpm/opensuse/suricata\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11207-1"}],"prev":{"headline":"Multiple vulnerabilities in the Repasat application","id":"CVE-2026-59673"},"products":["openSUSE Tumbleweed"],"published":"2026-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["SUSE"]},"summary":"The suricata user can escalate to root privileges via a symlink following vulnerability in the package installation script.","url":"https://insights.sbomify.com/CVE-2026-59674/"}