{"answers":{"affected":"3 open source packages ship an affected version, including mpp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59695 exists.","fix":"Upgrade mpp to 0.6.0 or later.","what":"CVE-2026-59695 is a high-severity vulnerability in ZenHive mpp, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59695 and fix it if it is affected.\n\nWhat it is: CVE-2026-59695 is a high-severity vulnerability in ZenHive mpp, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59695 exists.\n\nAffected packages and fixed versions:\n- mpp (Hex): affected from 0.2.0; fixed in 0.6.0\n- mpp (Hex): affected from 0.2.0; fixed in 0.6.0\n- mpp (Hex): affected from 0.2.0; fixed in 0.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59695/ (Markdown: https://insights.sbomify.com/CVE-2026-59695/index.md)","id":"CVE-2026-59695","markdown":"https://insights.sbomify.com/CVE-2026-59695/index.md","name":"CVE-2026-59695","record":{"aliases":["EEF-CVE-2026-59695","GHSA-6v7f-h3qg-wwpp","GHSA-vv77-66rf-pm86"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Elixir blockchain library","requires_auth":"none","summary":"An attacker can drain the fee-payer wallet by submitting transactions with arbitrarily high gas prices, causing financial loss and service disruption.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"Improper Validation of Specified Quantity in Input in ZenHive mpp allows an unauthenticated remote client to drain the fee-payer wallet in a single request by naming an arbitrarily high gas price.\n\nWhen the mpp Elixir library is configured as fee payer (fee_payer: true), MPP.Tempo.Transaction.cosign_fee_payer/3 re-signs the client-supplied base fields of the 0x76 AASigned envelope verbatim, including max_fee_per_gas and max_priority_fee_per_gas, without validating that they are within reasonable bounds. A malicious client embeds arbitrarily large values for these fields in the signed envelope. The server co-signs and broadcasts the transaction. The effective_gas_price billed against the fee-payer wallet is derived from the attacker-supplied ceilings, so the server pays those inflated per-gas rates out of its own wallet. A single crafted request can drain the wallet entirely, after which the server can no longer sponsor gas for legitimate payment requests.\n\nThis issue affects mpp: from 0.2.0 before 0.6.0.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Unbounded max_fee_per_gas in mpp Tempo fee-payer enables single-request wallet drain","id":"CVE-2026-59695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"uri_string does not bound the port component of a URI before integer conversion","id":"CVE-2026-59696"},"packages":[{"ecosystem":"Hex","fixed":["0.6.0"],"introduced":["0.2.0"],"last_affected":[],"package":"mpp","purl":"pkg:hex/mpp","source":"EEF-CVE-2026-59695"},{"ecosystem":"Hex","fixed":["0.6.0"],"introduced":["0.2.0"],"last_affected":[],"package":"mpp","purl":null,"source":"GHSA-vv77-66rf-pm86"},{"ecosystem":"Hex","fixed":["0.6.0"],"introduced":["0.2.0"],"last_affected":[],"package":"mpp","purl":"pkg:hex/mpp","source":"GHSA-vv77-66rf-pm86"}],"prev":{"headline":"Unbounded access list in mpp Tempo fee-payer inflates gas cost per payment","id":"CVE-2026-59694"},"products":["mpp"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-18","vendors":["ZenHive"]},"summary":"An attacker can drain the fee-payer wallet by submitting transactions with arbitrarily high gas prices, causing financial loss and service disruption.","url":"https://insights.sbomify.com/CVE-2026-59695/"}