# CVE-2026-59695: Unbounded max_fee_per_gas in mpp Tempo fee-payer enables single-request wallet drain

> An attacker can drain the fee-payer wallet by submitting transactions with arbitrarily high gas prices, causing financial loss and service disruption.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** EEF-CVE-2026-59695, GHSA-6v7f-h3qg-wwpp, GHSA-vv77-66rf-pm86

## What is CVE-2026-59695?

CVE-2026-59695 is a high-severity vulnerability in ZenHive mpp, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Validation of Specified Quantity in Input in ZenHive mpp allows an unauthenticated remote client to drain the fee-payer wallet in a single request by naming an arbitrarily high gas price.

When the mpp Elixir library is configured as fee payer (fee_payer: true), MPP.Tempo.Transaction.cosign_fee_payer/3 re-signs the client-supplied base fields of the 0x76 AASigned envelope verbatim, including max_fee_per_gas and max_priority_fee_per_gas, without validating that they are within reasonable bounds. A malicious client embeds arbitrarily large values for these fields in the signed envelope. The server co-signs and broadcasts the transaction. The effective_gas_price billed against the fee-payer wallet is derived from the attacker-supplied ceilings, so the server pays those inflated per-gas rates out of its own wallet. A single crafted request can drain the wallet entirely, after which the server can no longer sponsor gas for legitimate payment requests.

This issue affects mpp: from 0.2.0 before 0.6.0.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-59695?

3 open source packages ship an affected version, including mpp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpp` | Hex | From 0.2.0 | 0.6.0 |
| `mpp` | Hex | From 0.2.0 | 0.6.0 |
| `mpp` | Hex | From 0.2.0 | 0.6.0 |

## How do I fix CVE-2026-59695?

Upgrade mpp to 0.6.0 or later.

## Is CVE-2026-59695 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59695 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59695 and fix it if it is affected.

What it is: CVE-2026-59695 is a high-severity vulnerability in ZenHive mpp, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59695 exists.

Affected packages and fixed versions:
- mpp (Hex): affected from 0.2.0; fixed in 0.6.0
- mpp (Hex): affected from 0.2.0; fixed in 0.6.0
- mpp (Hex): affected from 0.2.0; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59695/ (Markdown: https://insights.sbomify.com/CVE-2026-59695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59695
- OSV: https://osv.dev/vulnerability/CVE-2026-59695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59695/
Summaries are generated and may contain mistakes; the official description above is the record.
