# CVE-2026-59714: Open WebUI: Cross-channel message overwrite via chat completion API (single-model and multimodel message_ids)

> Authenticated users can overwrite messages in private channels they do not belong to by manipulating chat completion API parameters.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-x2ff-v5v8-m75m, PYSEC-2026-3605

## What is CVE-2026-59714?

CVE-2026-59714 is a high-severity missing authorization vulnerability in open-webui, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.9.5 before 0.10.0, any authenticated user can overwrite the content of a message in a channel they do not belong to (including private and DM channels) by sending a chat completion request with a channel:-prefixed chat_id and a target message_id. The channel: path routes pipeline output through _make_channel_emitter, which writes to the Messages table using the caller-supplied message_id without binding it to the channel. This issue is fixed in version 0.10.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-59714?

3 open source packages ship an affected version, including open-webui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.9.5 | 0.10.0 |
| `open-webui` | PyPI | From 0.9.5 | 0.10.0 |
| `open-webui` | PyPI | From 0.9.5 | 0.10.0 |

## How do I fix CVE-2026-59714?

Upgrade open-webui to 0.10.0 or later.

## Is CVE-2026-59714 being exploited?

There is no known exploitation of CVE-2026-59714 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59714 and fix it if it is affected.

What it is: CVE-2026-59714 is a high-severity missing authorization vulnerability in open-webui, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59714 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.9.5; fixed in 0.10.0
- open-webui (PyPI): affected from 0.9.5; fixed in 0.10.0
- open-webui (PyPI): affected from 0.9.5; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59714/ (Markdown: https://insights.sbomify.com/CVE-2026-59714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59714
- OSV: https://osv.dev/vulnerability/CVE-2026-59714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59714/
Summaries are generated and may contain mistakes; the official description above is the record.
