# CVE-2026-59724: Socket.IO: Engine.IO WebTransport SID DoS

> Attackers can cause a denial of service in Socket.IO servers by sending crafted session IDs during WebTransport upgrades, requiring WebTransport to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLSA-2026-1792193356, GHSA-gr94-w7qr-f4j3, MINI-c3rp-5fq7-xqx8, MINI-c667-m673-hpvc, ROOT-APP-NPM-CVE-2026-59724

## What is CVE-2026-59724?

CVE-2026-59724 is a high-severity denial of service vulnerability in socketio socket.io, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Socket.IO enables bidirectional and low-latency communication for every platform. From 6.5.0 before 6.6.7, Engine.IO servers with WebTransport enabled can resolve a crafted session ID such as __proto__ through an inherited property of the clients object during WebTransport upgrade handling, causing a TypeError and denial of service. This issue is fixed in version 6.6.7.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-59724?

2 open source packages ship an affected version, including engine.io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `engine.io` | npm | From 6.5.0 | 6.6.7 |
| `engine.io` | npm | From 6.5.0 | 6.6.7 |

Products: Socket Engine.io.

## How do I fix CVE-2026-59724?

Upgrade engine.io to 6.6.7 or later.

## Is CVE-2026-59724 being exploited?

There is no known exploitation of CVE-2026-59724 in the wild and no public exploit code.

## Other vulnerabilities in socketio socket.io

- [CVE-2026-59725](https://insights.sbomify.com/CVE-2026-59725/): Socket.IO: Engine.IO Polling Transport Connection Exhaustion (high 7.5)
- [CVE-2022-21676](https://insights.sbomify.com/CVE-2022-21676/): Uncaught Exception in engine.io (high 7.5)
- [CVE-2020-36048](https://insights.sbomify.com/CVE-2020-36048/): Resource exhaustion in engine.io (high 7.5)
- [CVE-2022-41940](https://insights.sbomify.com/CVE-2022-41940/): Uncaught exception in engine.io (high 7.1)
- [CVE-2023-31125](https://insights.sbomify.com/CVE-2023-31125/): Uncaught exception in engine.io (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59724 and fix it if it is affected.

What it is: CVE-2026-59724 is a high-severity denial of service vulnerability in socketio socket.io, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59724 in the wild and no public exploit code.

Affected packages and fixed versions:
- engine.io (npm): affected from 6.5.0; fixed in 6.6.7
- engine.io (npm): affected from 6.5.0; fixed in 6.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59724/ (Markdown: https://insights.sbomify.com/CVE-2026-59724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59724
- OSV: https://osv.dev/vulnerability/CVE-2026-59724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59724/
Summaries are generated and may contain mistakes; the official description above is the record.
