# CVE-2026-59763: Unbounded Arch package file metadata can cause resource amplification in Gitea package uploads

> Attackers can cause resource amplification and denial of service by uploading Arch packages with unbounded metadata to Gitea.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-9mq6-mqjj-c2c5, GO-2026-6049, MINI-jcxj-wcxw-f3v3, MINI-xg9g-jpq5-94hg

## What is CVE-2026-59763?

CVE-2026-59763 is a medium-severity denial of service vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unbounded Arch package file metadata can cause resource amplification in Gitea package uploads

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-59763?

3 open source packages ship an affected version, including code.gitea.io/gitea and gitea.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-59763?

Upgrade code.gitea.io/gitea to 1.27.0 or later.

## Is CVE-2026-59763 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59763 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59763 and fix it if it is affected.

What it is: CVE-2026-59763 is a medium-severity denial of service vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59763 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59763/ (Markdown: https://insights.sbomify.com/CVE-2026-59763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59763
- OSV: https://osv.dev/vulnerability/CVE-2026-59763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59763/
Summaries are generated and may contain mistakes; the official description above is the record.
