CVE-2026-59780 Apache CloudStack: LDAP provider configuration disclosure

High 7.5 Published Updated

Authenticated users can view sensitive LDAP configuration details via the listLdapConfigurations API, exposing credentials or settings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-59780?

CVE-2026-59780 is a high-severity vulnerability in Apache Cloudstack, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's LDAP authentication plugin while listing LDAP providers.

LDAP configurations can be listed by any authenticated user with access to the listLdapConfigurations API. By default, this API is available to all default roles.

This issue affects Apache CloudStack: from 4.2.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-59780?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-59780?

No fix has been published for CVE-2026-59780 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-59780 being exploited?

There is no known exploitation of CVE-2026-59780 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-8g4h-4jg3-6x4f.

Is CVE-2026-59780 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free