CVE-2026-59799 Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow

High 8.8 Published Updated

Attackers can bypass two-factor authentication disable flow due to missing privilege checks in Apache CloudStack.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-59799?

CVE-2026-59799 is a high-severity missing authorization vulnerability in Apache Cloudstack, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow.

This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-269

Which versions are affected by CVE-2026-59799?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-59799?

No fix has been published for CVE-2026-59799 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-59799 being exploited?

There is no known exploitation of CVE-2026-59799 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-vw73-w3p2-w2rj.

Is CVE-2026-59799 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free