{"answers":{"affected":"2 open source packages ship an affected version, including 9router.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59800 exists.","fix":"Upgrade 9router to 0.4.44 or later.","what":"CVE-2026-59800 is a critical command injection vulnerability in decolua 9router, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59800 and fix it if it is affected.\n\nWhat it is: CVE-2026-59800 is a critical command injection vulnerability in decolua 9router, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59800 exists.\n\nAffected packages and fixed versions:\n- 9router (npm): affected all versions; fixed in 0.4.44\n- 9router (npm): affected all versions; fixed in 0.4.44\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59800/ (Markdown: https://insights.sbomify.com/CVE-2026-59800/index.md)","id":"CVE-2026-59800","markdown":"https://insights.sbomify.com/CVE-2026-59800/index.md","name":"CVE-2026-59800","record":{"aliases":["GHSA-g6g7-pvmx-m74p"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"9Router server","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary OS commands via the sudoPassword parameter in the Tailscale install endpoint when sudo does not prompt for a password.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"9Router before 0.4.44 contains an OS command injection vulnerability in the unauthenticated POST /api/tunnel/tailscale-install endpoint (this route is not covered by the dashboard middleware matcher, so no authorization check is applied). The sudoPassword field from the request body is written to the stdin of a 'sudo -S sh' child process. When sudo does not prompt for a password (the process runs as root, NOPASSWD is configured, or a recent sudo timestamp cache exists), the sudoPassword value is interpreted by sh as a shell command, allowing a remote unauthenticated attacker to execute arbitrary OS commands. Exploitation evidence was first observed by the Shadowserver Foundation on 2026-07-04 (UTC).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"9Router \u003c 0.4.44 - OS Command Injection via sudoPassword Parameter in Tailscale Install Endpoint","id":"CVE-2026-59800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"9Router 0.4.41 - Unauthenticated API Exposure via /api/providers","id":"CVE-2026-59801"},"packages":[{"ecosystem":"npm","fixed":["0.4.44"],"introduced":["0"],"last_affected":[],"package":"9router","purl":null,"source":"GHSA-g6g7-pvmx-m74p"},{"ecosystem":"npm","fixed":["0.4.44"],"introduced":["0"],"last_affected":[],"package":"9router","purl":"pkg:npm/9router","source":"GHSA-g6g7-pvmx-m74p"}],"prev":{"headline":"Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow","id":"CVE-2026-59799"},"products":["9router"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-07","vendors":["decolua"]},"summary":"Unauthenticated attackers can execute arbitrary OS commands via the sudoPassword parameter in the Tailscale install endpoint when sudo does not prompt for a password.","url":"https://insights.sbomify.com/CVE-2026-59800/"}