# CVE-2026-59800: 9Router < 0.4.44 - OS Command Injection via sudoPassword Parameter in Tailscale Install Endpoint

> Unauthenticated attackers can execute arbitrary OS commands via the sudoPassword parameter in the Tailscale install endpoint when sudo does not prompt for a password.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-g6g7-pvmx-m74p

## What is CVE-2026-59800?

CVE-2026-59800 is a critical command injection vulnerability in decolua 9router, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router before 0.4.44 contains an OS command injection vulnerability in the unauthenticated POST /api/tunnel/tailscale-install endpoint (this route is not covered by the dashboard middleware matcher, so no authorization check is applied). The sudoPassword field from the request body is written to the stdin of a 'sudo -S sh' child process. When sudo does not prompt for a password (the process runs as root, NOPASSWD is configured, or a recent sudo timestamp cache exists), the sudoPassword value is interpreted by sh as a shell command, allowing a remote unauthenticated attacker to execute arbitrary OS commands. Exploitation evidence was first observed by the Shadowserver Foundation on 2026-07-04 (UTC).

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-59800?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.4.44 |
| `9router` | npm | All versions | 0.4.44 |

## How do I fix CVE-2026-59800?

Upgrade 9router to 0.4.44 or later.

## Is CVE-2026-59800 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59800 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59800 and fix it if it is affected.

What it is: CVE-2026-59800 is a critical command injection vulnerability in decolua 9router, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59800 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.4.44
- 9router (npm): affected all versions; fixed in 0.4.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59800/ (Markdown: https://insights.sbomify.com/CVE-2026-59800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59800
- OSV: https://osv.dev/vulnerability/CVE-2026-59800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59800/
Summaries are generated and may contain mistakes; the official description above is the record.
