# CVE-2026-59814: Joplin: Stored XSS via inline-served note attachment on published shares

> Attackers can inject scripts via malicious attachments in shared notes, allowing session hijacking and data theft on Joplin Server.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-mx98-7h4g-6gmh

## What is CVE-2026-59814?

CVE-2026-59814 is a high-severity cross-site scripting vulnerability in laurent22 joplin, published on 21 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Joplin is an open source note-taking and to-do application that organises notes and lists into notebooks. Prior to 3.7.7, Joplin Server's GET /shares/:id?resource_id= route serves a resource with the attacker-controlled mime value and omits Content-Disposition when the resource title is empty. A low-privileged user can publish an empty-title image/svg+xml attachment whose script executes when a victim opens the public share. By default, user content shares the Joplin Server application origin, allowing the script to access same-origin data and, when the victim is authenticated, perform actions with the victim's session, including reading administrative data and anti-CSRF tokens. Installations that configure USER_CONTENT_BASE_URL to a separate origin still execute the script, but on that separate user-content origin rather than the application origin. This issue is fixed in version 3.7.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-59814?


## How do I fix CVE-2026-59814?

No fix has been published for CVE-2026-59814 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59814 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59814 and fix it if it is affected.

What it is: CVE-2026-59814 is a high-severity cross-site scripting vulnerability in laurent22 joplin, published on 21 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59814 exists.

Affected product: laurent22 joplin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59814/ (Markdown: https://insights.sbomify.com/CVE-2026-59814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59814
- OSV: https://osv.dev/vulnerability/CVE-2026-59814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59814/
Summaries are generated and may contain mistakes; the official description above is the record.
