# CVE-2026-59818: etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation

> Attackers with revoked certificates can bypass CRL checks on gRPC listeners in etcd when HTTP and gRPC endpoints are split, allowing unauthorized access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** AZL-92141, BELL-CVE-2026-59818, BIT-etcd-2026-59818, DEBIAN-CVE-2026-59818, GHSA-3wh4-j44w-pg92, MINI-2p3r-7mx5-hg5j, MINI-739v-hgjw-4cc6, MINI-9mrf-3jfg-xwpj, MINI-gcw7-vg28-79g3, MINI-j3m4-4h37-2cjh, MINI-xvfg-g75v-x7q5, UBUNTU-CVE-2026-59818

## What is CVE-2026-59818?

CVE-2026-59818 is a medium-severity vulnerability in etcd-io etcd, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

etcd is a distributed key-value store for the data of a distributed system. Prior to 3.5.32 and 3.6.13, when etcd is configured with --listen-client-http-urls to split HTTP and gRPC client endpoints onto separate listeners, the --client-crl-file Certificate Revocation List is not enforced on the gRPC listener, allowing a client with a revoked certificate to authenticate successfully over gRPC. This issue is fixed in versions 3.5.32 and 3.6.13.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-59818?

1 open source package ship an affected version, including etcd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `etcd` | Bitnami | All versions | 3.5.32, 3.6.13 |

Products: Etcd Etcd.

## How do I fix CVE-2026-59818?

Upgrade etcd to a fixed version for your release line: 3.5.32 or 3.6.13.

## Is CVE-2026-59818 being exploited?

There is no known exploitation of CVE-2026-59818 in the wild and no public exploit code.

## Other vulnerabilities in etcd-io etcd

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2020-15106](https://insights.sbomify.com/CVE-2020-15106/): Improper Input Validation in etcd (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59818 and fix it if it is affected.

What it is: CVE-2026-59818 is a medium-severity vulnerability in etcd-io etcd, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59818 in the wild and no public exploit code.

Affected packages and fixed versions:
- etcd (Bitnami): affected all versions; fixed in 3.5.32, 3.6.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59818/ (Markdown: https://insights.sbomify.com/CVE-2026-59818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59818
- OSV: https://osv.dev/vulnerability/CVE-2026-59818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59818/
Summaries are generated and may contain mistakes; the official description above is the record.
