# CVE-2026-59819: LiteLLM: Local file read via request-supplied OIDC file references

> Privileged users can read local files via OIDC file references in the health test connection endpoint of the LiteLLM proxy server.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** ECHO-ab2a-73d9-3aa2, GHSA-4g5m-c9r5-49xf, MINI-4p87-r3j3-f39c, MINI-76cr-gqm7-q44w, MINI-jprv-grp2-jhxf, MINI-m95w-3j6m-fmm4, MINI-qm88-mh8w-p76r, MINI-rrh9-rj72-75jg, PYSEC-2026-3476

## What is CVE-2026-59819?

CVE-2026-59819 is a low-severity path traversal vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.10-stable, LiteLLM's /health/test_connection endpoint resolved request-supplied environment and OIDC file references in litellm_params, allowing a proxy administrator or another privileged caller with permission to test model connections to read files from the local filesystem via an oidc/file/ reference. This issue is fixed in version 1.83.10-stable.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-59819?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.10 |
| `litellm` | PyPI | All versions | 1.83.10 |
| `litellm` | PyPI | All versions | 1.83.10 |

Products: Litellm Litellm.

## How do I fix CVE-2026-59819?

Upgrade litellm to 1.83.10 or later.

## Is CVE-2026-59819 being exploited?

There is no known exploitation of CVE-2026-59819 in the wild and no public exploit code.

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59819 and fix it if it is affected.

What it is: CVE-2026-59819 is a low-severity path traversal vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59819 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.10
- litellm (PyPI): affected all versions; fixed in 1.83.10
- litellm (PyPI): affected all versions; fixed in 1.83.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59819/ (Markdown: https://insights.sbomify.com/CVE-2026-59819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59819
- OSV: https://osv.dev/vulnerability/CVE-2026-59819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59819/
Summaries are generated and may contain mistakes; the official description above is the record.
