# CVE-2026-59820: LiteLLM: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

> Authenticated users can upload crafted skill archives to write files outside the intended directory via path traversal in LiteLLM.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** ECHO-15ef-6486-8fd7, GHSA-5jmr-gcrj-2c9q, MINI-2xj5-fpg4-vr8x, MINI-6phm-8mq6-g52j, MINI-8m5q-qxph-pcqr, MINI-j62p-8h4x-cf75, MINI-jfxf-6fpp-6553, MINI-r3x7-fv9c-p295, PYSEC-2026-3477

## What is CVE-2026-59820?

CVE-2026-59820 is a medium-severity path traversal vulnerability in BerriAI litellm, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.7-stable, LiteLLM Skills archive extraction did not sufficiently validate file paths from uploaded skill ZIP archives, allowing an authenticated user with access to LiteLLM LLM API routes or a key whose allowed_routes includes /v1/skills, anthropic_routes, or llm_api_routes to upload a crafted skill archive containing path traversal entries that could be written outside the intended extraction or staging directory. This issue is fixed in version 1.83.7-stable.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59820?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.7 |
| `litellm` | PyPI | All versions | 1.83.7 |
| `litellm` | PyPI | All versions | 1.83.7 |

Products: Litellm Litellm.

## How do I fix CVE-2026-59820?

Upgrade litellm to 1.83.7 or later.

## Is CVE-2026-59820 being exploited?

There is no known exploitation of CVE-2026-59820 in the wild and no public exploit code.

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59820 and fix it if it is affected.

What it is: CVE-2026-59820 is a medium-severity path traversal vulnerability in BerriAI litellm, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59820 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.7
- litellm (PyPI): affected all versions; fixed in 1.83.7
- litellm (PyPI): affected all versions; fixed in 1.83.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59820/ (Markdown: https://insights.sbomify.com/CVE-2026-59820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59820
- OSV: https://osv.dev/vulnerability/CVE-2026-59820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59820/
Summaries are generated and may contain mistakes; the official description above is the record.
