{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-59821 in the wild and no public exploit code.","fix":"Upgrade litellm to 1.82.0 or later.","what":"CVE-2026-59821 is a low-severity code injection vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59821 and fix it if it is affected.\n\nWhat it is: CVE-2026-59821 is a low-severity code injection vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59821 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.82.0\n- litellm (PyPI): affected all versions; fixed in 1.82.0\n- litellm (PyPI): affected all versions; fixed in 1.82.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59821/ (Markdown: https://insights.sbomify.com/CVE-2026-59821/index.md)","id":"CVE-2026-59821","markdown":"https://insights.sbomify.com/CVE-2026-59821/index.md","name":"CVE-2026-59821","record":{"aliases":["ECHO-4543-9144-2cc5","GHSA-72m8-9m7m-h278","MINI-93mg-g88v-7f42","MINI-mc35-mprm-v54q","MINI-r8m4-cr69-v9g3","MINI-x8qv-vw88-8cxr","PYSEC-2026-3478"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI Gateway Proxy","requires_auth":"high_privilege","summary":"Privileged users can bypass safety checks to execute arbitrary Python code in the LiteLLM proxy, potentially exposing secrets.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks","id":"CVE-2026-59821","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822"},"packages":[{"ecosystem":"PyPI","fixed":["1.82.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-72m8-9m7m-h278"},{"ecosystem":"PyPI","fixed":["1.82.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-72m8-9m7m-h278"},{"ecosystem":"PyPI","fixed":["1.82.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-3478"}],"prev":{"headline":"LiteLLM: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","id":"CVE-2026-59820"},"products":["litellm"],"published":"2026-07-08","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["BerriAI"]},"summary":"Privileged users can bypass safety checks to execute arbitrary Python code in the LiteLLM proxy, potentially exposing secrets.","url":"https://insights.sbomify.com/CVE-2026-59821/"}