# CVE-2026-59821: LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks

> Privileged users can bypass safety checks to execute arbitrary Python code in the LiteLLM proxy, potentially exposing secrets.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** ECHO-4543-9144-2cc5, GHSA-72m8-9m7m-h278, MINI-93mg-g88v-7f42, MINI-mc35-mprm-v54q, MINI-r8m4-cr69-v9g3, MINI-x8qv-vw88-8cxr, PYSEC-2026-3478

## What is CVE-2026-59821?

CVE-2026-59821 is a low-severity code injection vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-59821?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.82.0 |
| `litellm` | PyPI | All versions | 1.82.0 |
| `litellm` | PyPI | All versions | 1.82.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-59821?

Upgrade litellm to 1.82.0 or later.

## Is CVE-2026-59821 being exploited?

There is no known exploitation of CVE-2026-59821 in the wild and no public exploit code.

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59821 and fix it if it is affected.

What it is: CVE-2026-59821 is a low-severity code injection vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59821 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.82.0
- litellm (PyPI): affected all versions; fixed in 1.82.0
- litellm (PyPI): affected all versions; fixed in 1.82.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59821/ (Markdown: https://insights.sbomify.com/CVE-2026-59821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59821
- OSV: https://osv.dev/vulnerability/CVE-2026-59821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59821/
Summaries are generated and may contain mistakes; the official description above is the record.
