{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2026-59822 in the wild since at least 2 Sep 2026.","fix":"Upgrade litellm to 1.84.0 or later. US federal agencies must fix it by 16 Sep 2026.","what":"CVE-2026-59822 is a high-severity authentication bypass vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59822 and fix it if it is affected.\n\nWhat it is: CVE-2026-59822 is a high-severity authentication bypass vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2026-59822 in the wild since at least 2 Sep 2026.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.84.0\n- litellm (PyPI): affected all versions; fixed in 1.84.0\n- litellm (PyPI): affected all versions; fixed in 1.84.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59822/ (Markdown: https://insights.sbomify.com/CVE-2026-59822/index.md)","id":"CVE-2026-59822","markdown":"https://insights.sbomify.com/CVE-2026-59822/index.md","name":"CVE-2026-59822","record":{"aliases":["ECHO-7929-641d-77eb","GHSA-7488-6r32-c95q","MINI-24xw-2vfx-m836","MINI-8wpr-cg2h-mm32","MINI-gj2x-9328-hw8v","MINI-h5jw-cp5c-g26h","MINI-pwgf-mprj-c2w9","MINI-xch4-cjhj-rc48","PYSEC-2026-3479"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI Gateway Proxy","requires_auth":"none","summary":"Unauthenticated attackers can bypass LiteLLM key validation via OAuth2 fallback to access MCP tooling without valid credentials.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-09-03","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-03T06:10:22Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-2026-59822","stars":0,"title":"CVE-2026-59822 - Draft or TODO"}],"tier":"exploited"},"has_fix":true,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","indexable":true,"kev":{"dateAdded":"2026-09-02","dueDate":"2026-09-16","knownRansomwareCampaignUse":"Unknown","product":"LiteLLM","requiredAction":"Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.","vendorProject":"BerriAI","vulnerabilityName":"BerriAI LiteLLM Improper Authentication Vulnerability"},"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"LiteLLM: Server-side request forgery via the `user_config` request parameter in LiteLLM Proxy","id":"CVE-2026-59823"},"packages":[{"ecosystem":"PyPI","fixed":["1.84.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-7488-6r32-c95q"},{"ecosystem":"PyPI","fixed":["1.84.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-7488-6r32-c95q"},{"ecosystem":"PyPI","fixed":["1.84.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-3479"}],"prev":{"headline":"LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks","id":"CVE-2026-59821"},"products":["litellm"],"published":"2026-07-08","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-03","vendors":["BerriAI"]},"summary":"Unauthenticated attackers can bypass LiteLLM key validation via OAuth2 fallback to access MCP tooling without valid credentials.","url":"https://insights.sbomify.com/CVE-2026-59822/"}