# CVE-2026-59822: BerriAI LiteLLM Improper Authentication

> Unauthenticated attackers can bypass LiteLLM key validation via OAuth2 fallback to access MCP tooling without valid credentials.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Yes, since 2 Sep 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 3 Sep 2026
- **Also known as:** ECHO-7929-641d-77eb, GHSA-7488-6r32-c95q, MINI-24xw-2vfx-m836, MINI-8wpr-cg2h-mm32, MINI-gj2x-9328-hw8v, MINI-h5jw-cp5c-g26h, MINI-pwgf-mprj-c2w9, MINI-xch4-cjhj-rc48, PYSEC-2026-3479

## What is CVE-2026-59822?

CVE-2026-59822 is a high-severity authentication bypass vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-59822?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-59822?

Upgrade litellm to 1.84.0 or later. US federal agencies must fix it by 16 Sep 2026.

## Is CVE-2026-59822 being exploited?

Yes. Attackers have exploited CVE-2026-59822 in the wild since at least 2 Sep 2026.

Public exploit code:

- CVE-2026-59822 - Draft or TODO (github_poc): https://github.com/HORKimhab/CVE-2026-59822

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)
- [CVE-2026-49468](https://insights.sbomify.com/CVE-2026-49468/): LiteLLM: Authentication Bypass via Host Header Injection (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59822 and fix it if it is affected.

What it is: CVE-2026-59822 is a high-severity authentication bypass vulnerability in BerriAI litellm, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-59822 in the wild since at least 2 Sep 2026.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59822/ (Markdown: https://insights.sbomify.com/CVE-2026-59822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59822
- OSV: https://osv.dev/vulnerability/CVE-2026-59822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59822/
Summaries are generated and may contain mistakes; the official description above is the record.
