{"answers":{"affected":"3 open source packages ship an affected version, including litellm.","exploited":"There is no known exploitation of CVE-2026-59823 in the wild and no public exploit code.","fix":"Upgrade litellm to 1.83.9 or later.","what":"CVE-2026-59823 is a medium-severity server-side request forgery vulnerability in BerriAI litellm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59823 and fix it if it is affected.\n\nWhat it is: CVE-2026-59823 is a medium-severity server-side request forgery vulnerability in BerriAI litellm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59823 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.83.9\n- litellm (PyPI): affected all versions; fixed in 1.83.9\n- litellm (PyPI): affected all versions; fixed in 1.83.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59823/ (Markdown: https://insights.sbomify.com/CVE-2026-59823/index.md)","id":"CVE-2026-59823","markdown":"https://insights.sbomify.com/CVE-2026-59823/index.md","name":"CVE-2026-59823","record":{"aliases":["ECHO-312d-3fe3-ae81","GHSA-hx8v-g79f-8w5f","MINI-9hqf-57ff-x92m","MINI-ggxq-v7j5-3cwv","MINI-j38m-7f5r-pc3g","MINI-pwf2-rf9p-3477","MINI-q2hg-692v-434q","MINI-x3w9-j9p2-h26p","PYSEC-2026-4070"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM AI Gateway","requires_auth":"low_privilege","summary":"Authenticated users can exploit a validation bypass in LiteLLM Proxy to redirect server-side requests to internal or external hosts, potentially exposing restricted endpoints.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.9, an authenticated LiteLLM Proxy caller with a valid virtual key can place api_base inside the user_config request body to bypass is_request_body_safe, which blocks top-level api_base and base_url but previously did not inspect or reject user_config. Because user_config constructs the outbound router, the nested destination redirects a server-side request to an internal or external host selected by the caller and can expose endpoints the caller cannot otherwise access. This issue is fixed in version 1.83.9.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LiteLLM: Server-side request forgery via the `user_config` request parameter in LiteLLM Proxy","id":"CVE-2026-59823","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Mastodon: Unwanted deactivation of SSL/TLS certificate verification","id":"CVE-2026-59825"},"packages":[{"ecosystem":"PyPI","fixed":["1.83.9"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-hx8v-g79f-8w5f"},{"ecosystem":"PyPI","fixed":["1.83.9"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-hx8v-g79f-8w5f"},{"ecosystem":"PyPI","fixed":["1.83.9"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-4070"}],"prev":{"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822"},"products":["litellm"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["BerriAI"]},"summary":"Authenticated users can exploit a validation bypass in LiteLLM Proxy to redirect server-side requests to internal or external hosts, potentially exposing restricted endpoints.","url":"https://insights.sbomify.com/CVE-2026-59823/"}