# CVE-2026-59827: Metabase: Unsafe Deserialization of H2 Query Results

> Authenticated users can execute arbitrary code on Metabase servers by exploiting unsafe deserialization of H2 query results.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-w95f-x9v9-wv36

## What is CVE-2026-59827?

CVE-2026-59827 is a critical unsafe deserialization vulnerability in metabase, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Metabase is an open-source business intelligence and embedded analytics tool. Prior to 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4, Metabase instances with an H2 database connection, including the default sample database, deserialize arbitrary Java objects returned in H2 native query result columns of type OTHER without validation, allowing an authenticated user who can run native H2 queries to execute code on the Metabase server. This issue is fixed in versions 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-59827?

It affects 1 product.


Products: Metabase Metabase.

## How do I fix CVE-2026-59827?

No fix has been published for CVE-2026-59827 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59827 being exploited?

There is no known exploitation of CVE-2026-59827 in the wild and no public exploit code.

Public exploit code:

- Technical analysis and proof of concept for CVE-2026-59827, a critical unsafe Java deserialization vulnerability in Metabase leading to remote code execution. (github_poc): https://github.com/Gutierre0x80/CVE-2026-59827
- Metabase CVE-2026-59827 Vulnerability Scanner (github_poc): https://github.com/pickl31/CVE-2026-59827
- Blog on CVE-2026-59827, Unsafe H2 query ouput deserialization (github_poc): https://github.com/c0gnit00/CVE-2026-59827
- Metabase 0.61.0  - Authenticated Remote Code Execution (exploitdb)
- Educational cyber range for CVE-2026-59827 (Metabase H2 unsafe deserialization / CWE-502). Isolated Docker lab — training only, not for attacking production Metabase. (github_poc): https://github.com/shivammittal2403/cve-2026-59827-metabase-cyber-range

## Other vulnerabilities in metabase

- [CVE-2026-72898](https://insights.sbomify.com/CVE-2026-72898/): Metabase SQL Injection (critical 10.0, exploited in the wild)
- [CVE-2021-41277](https://insights.sbomify.com/CVE-2021-41277/): Metabase GeoJSON API Local File Inclusion (critical 10.0, exploited in the wild)
- [CVE-2026-50148](https://insights.sbomify.com/CVE-2026-50148/): Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write (critical 10.0)
- [CVE-2023-37470](https://insights.sbomify.com/CVE-2023-37470/): Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint (critical 10.0)
- [CVE-2023-38646](https://insights.sbomify.com/CVE-2023-38646/): Command injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59827 and fix it if it is affected.

What it is: CVE-2026-59827 is a critical unsafe deserialization vulnerability in metabase, published on 9 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59827 in the wild and no public exploit code.

Affected product: metabase. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59827/ (Markdown: https://insights.sbomify.com/CVE-2026-59827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59827
- OSV: https://osv.dev/vulnerability/CVE-2026-59827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59827/
Summaries are generated and may contain mistakes; the official description above is the record.
