CVE-2026-59828 Discourse: Hidden post revisions leak through adjacent visible diffs

Medium 5.3 Published Updated

Attackers can view hidden post revisions by exploiting visible diffs on adjacent revisions, leaking sensitive content to unauthorized users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59828?

CVE-2026-59828 is a medium-severity vulnerability in Discourse Discourse, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, post revisions that should be hidden from regular users could be leaked through visible diffs on adjacent revisions serialized by PostRevisionSerializer. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

Weakness: CWE-200

Which versions are affected by CVE-2026-59828?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.5, 2026.4.2, 2026.5.1, 2026.7.0

Products include Discourse Discourse.

How do I fix CVE-2026-59828?

Upgrade discourse to a fixed version for your release line: 2026.1.5, 2026.4.2, 2026.5.1 or 2026.7.0.

Is CVE-2026-59828 being exploited?

There is no known exploitation of CVE-2026-59828 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-59828, GHSA-q456-4f8q-42vx.

Is CVE-2026-59828 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free