# CVE-2026-59829: Discourse: Review queue exposes flag-related private message excerpts to category group moderators

> Category group moderators can view unauthorized private message excerpts in the review queue on Discourse sites with category group moderation enabled.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** BIT-discourse-2026-59829, GHSA-wmc6-pmxp-xw5w

## What is CVE-2026-59829?

CVE-2026-59829 is a medium-severity missing authorization vulnerability in discourse, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.1, on sites with category group moderation enabled, the review queue could include an excerpt (and permalink) of the private message attached to a flag, even when the reviewing category moderator was not a participant in that message. These notify_moderators flag messages are addressed only to moderators and, for core flags, to a category's moderation groups as they existed when the flag was raised, so a category group moderator could read flag-discussion content they were not authorized to see. This affects official plugins that create such messages and core flags raised before a moderator's group was granted moderation of the category. Only the confidentiality of a limited excerpt of these flag-related private messages is affected; no content can be modified or deleted. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-59829?

1 open source package ship an affected version, including discourse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.6.1 |

## How do I fix CVE-2026-59829?

Upgrade discourse to 2026.6.1 or later.

## Is CVE-2026-59829 being exploited?

There is no known exploitation of CVE-2026-59829 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59829 and fix it if it is affected.

What it is: CVE-2026-59829 is a medium-severity missing authorization vulnerability in discourse, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59829 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59829/ (Markdown: https://insights.sbomify.com/CVE-2026-59829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59829
- OSV: https://osv.dev/vulnerability/CVE-2026-59829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59829/
Summaries are generated and may contain mistakes; the official description above is the record.
