# CVE-2026-59865: Kiota: Command injection via x-ms-kiota-info dependencyInstallCommand surfaced by `kiota info`

> Attackers can inject commands via malicious OpenAPI descriptions, leading to code execution when users run suggested install commands.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-hq9q-27g5-qwpj

## What is CVE-2026-59865?

CVE-2026-59865 is a critical command injection vulnerability in microsoft kiota, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.5, `kiota info` read x-ms-kiota-info.languagesInformation.<language>.dependencyInstallCommand plus dependency name and version values from an OpenAPI description and presented the spec-supplied command as Kiota's recommended install command, allowing an attacker-controlled or compromised description to cause command injection when the suggested command was run manually or through the Kiota VS Code extension's kiota info --json dependency-install flow. This issue is fixed in version 1.29.1 and 1.32.5.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-59865?

8 open source packages ship an affected version, including Microsoft.OpenApi.Kiota and Microsoft.OpenApi.Kiota.Builder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.OpenApi.Kiota` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | From 1.30.0 | 1.32.5 |

## How do I fix CVE-2026-59865?

Upgrade Microsoft.OpenApi.Kiota to a fixed version for your release line: 1.29.1 or 1.32.5.

## Is CVE-2026-59865 being exploited?

There is no known exploitation of CVE-2026-59865 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59865 and fix it if it is affected.

What it is: CVE-2026-59865 is a critical command injection vulnerability in microsoft kiota, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59865 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.OpenApi.Kiota (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected from 1.30.0; fixed in 1.32.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59865/ (Markdown: https://insights.sbomify.com/CVE-2026-59865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59865
- OSV: https://osv.dev/vulnerability/CVE-2026-59865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59865/
Summaries are generated and may contain mistakes; the official description above is the record.
