# CVE-2026-59867: Kiota: Generation-time SSRF + remote/local file inclusion via unrestricted $ref

> Attackers can trigger SSRF and file inclusion during code generation by manipulating OpenAPI $ref values, potentially leaking data or executing code.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-rg4h-fpcp-2qm8

## What is CVE-2026-59867?

CVE-2026-59867 is a high-severity server-side request forgery vulnerability in microsoft kiota, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.5, Kiota resolved OpenAPI $ref values by fetching remote http(s) URLs and reading local absolute or out-of-tree file paths, allowing `kiota generate` on an attacker-controlled or attacker-influenced description to perform build-time SSRF, remote file inclusion, and local file inclusion by inlining external schemas such as REMOTE_KIOTA_PROP or Leaked into generated clients. This issue is fixed in version 1.29.1 and 1.32.5 by AllowedExternalOriginsStreamLoader and the --allowed-external-origins option.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59867?

8 open source packages ship an affected version, including Microsoft.OpenApi.Kiota and Microsoft.OpenApi.Kiota.Builder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.OpenApi.Kiota` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | All versions | 1.29.1 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | From 1.30.0 | 1.32.5 |
| `Microsoft.OpenApi.Kiota.Builder` | NuGet | From 1.30.0 | 1.32.5 |

## How do I fix CVE-2026-59867?

Upgrade Microsoft.OpenApi.Kiota to a fixed version for your release line: 1.29.1 or 1.32.5.

## Is CVE-2026-59867 being exploited?

There is no known exploitation of CVE-2026-59867 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59867 and fix it if it is affected.

What it is: CVE-2026-59867 is a high-severity server-side request forgery vulnerability in microsoft kiota, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59867 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.OpenApi.Kiota (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected all versions; fixed in 1.29.1
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected from 1.30.0; fixed in 1.32.5
- Microsoft.OpenApi.Kiota.Builder (NuGet): affected from 1.30.0; fixed in 1.32.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59867/ (Markdown: https://insights.sbomify.com/CVE-2026-59867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59867
- OSV: https://osv.dev/vulnerability/CVE-2026-59867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59867/
Summaries are generated and may contain mistakes; the official description above is the record.
