# CVE-2026-59869: js-yaml: YAML merge-key chains can force quadratic CPU consumption

> Attackers can cause excessive CPU consumption and service unavailability by submitting crafted YAML documents with merge key chains to applications using js-yaml.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** AZL-92192, CLEANSTART-2026-JG14084, CLEANSTART-2026-LP47125, CLEANSTART-2026-LU28686, CLEANSTART-2026-QF29635, CLEANSTART-2026-RI71860, CLSA-2026-1784596292, CLSA-2026-1784683084, CLSA-2026-1790187722, CLSA-2026-1790522263, DEBIAN-CVE-2026-59869, ECHO-f76d-d47e-3947, GHSA-52cp-r559-cp3m, MINI-2h8x-5w4f-p6xc, MINI-3375-96wc-696c, MINI-366g-gqrp-cpxh, MINI-58pj-944c-vqq8, MINI-5fgc-9v8c-4889, MINI-6ffc-g34r-34xj, MINI-6q5f-68r3-437r, MINI-72m8-9q5m-xjw8, MINI-7hm6-j2cm-fxx6, MINI-8wg5-m23c-p2r7, MINI-8xc8-5gjw-hjx4, MINI-97mq-rfhp-jgqf, MINI-9v7f-ffm9-q47v, MINI-c37m-c6h6-fwr8, MINI-cgpg-rh4x-v2qh, MINI-cpqr-6xq9-fpx9, MINI-cr2g-3538-4f7j, MINI-g6w6-w5x8-rhv6, MINI-gc9m-hj3g-rvg8, MINI-gxpr-937m-6vfv, MINI-h465-x7xv-rv2x, MINI-jp3m-phq2-3m36, MINI-jvfv-2292-qx7f, MINI-mfvf-vw4w-jwwq, MINI-mwcw-5qqv-6vxh, MINI-p2jm-fcgw-mhg8, MINI-pjr9-7wxm-c67j, MINI-q7m6-99vm-6f46, MINI-qc26-9hgp-987p, MINI-qr95-5hq4-2m6j, MINI-v45w-5xq4-3r2m, MINI-v7j2-6wmf-f2w3, MINI-v9c9-69x5-6fxx, MINI-w2x4-f3h9-2gpw, RHSA-2026:37532, RHSA-2026:38304, ROOT-APP-NPM-CVE-2026-59869, UBUNTU-CVE-2026-59869

## What is CVE-2026-59869?

CVE-2026-59869 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-yaml is a JavaScript YAML parser and dumper. From 3.0.0 before 3.15.0 and from 4.0.0 before 4.3.0, js-yaml can spend quadratic CPU time parsing a document whose size grows only linearly when a chain of mappings uses merge keys where each mapping merges the previous one. This issue is fixed in versions 3.15.0 and 4.3.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-59869?

4 open source packages ship an affected version, including js-yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-yaml` | npm | From 3.0.0 | 3.15.0 |
| `js-yaml` | npm | From 3.0.0 | 3.15.0 |
| `js-yaml` | npm | From 4.0.0 | 4.3.0 |
| `js-yaml` | npm | From 4.0.0 | 4.3.0 |
| `nodejs22` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-bin` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-devel` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-docs` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-full-i18n` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-libs` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs22-npm` | Red Hat:hummingbird:1 | All versions | 0:10.9.8-1.22.23.1.2.1.hum1 |
| `nodejs22-npm-bin` | Red Hat:hummingbird:1 | All versions | 0:22.23.1-2.1.hum1 |
| `nodejs26` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-bin` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-devel` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-docs` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-full-i18n` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-libs` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `nodejs26-npm` | Red Hat:hummingbird:1 | All versions | 0:11.17.0-1.26.4.0.1.4.hum1 |
| `nodejs26-npm-bin` | Red Hat:hummingbird:1 | All versions | 0:26.4.0-1.4.hum1 |
| `v8-12.4-devel` | Red Hat:hummingbird:1 | All versions | 0:12.4.254.21-1.22.23.1.2.1.hum1 |
| `v8-14.6-devel` | Red Hat:hummingbird:1 | All versions | 0:14.6.202.34-1.26.4.0.1.4.hum1 |

Products: Nodeca Js-Yaml.

## How do I fix CVE-2026-59869?

Upgrade js-yaml to a fixed version for your release line: 3.15.0 or 4.3.0.

## Is CVE-2026-59869 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59869 exists.

## Other vulnerabilities in nodeca js-yaml

- [CVE-2026-59870](https://insights.sbomify.com/CVE-2026-59870/): js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing (high 7.5)
- [CVE-2013-4660](https://insights.sbomify.com/CVE-2013-4660/): Deserialization Code Execution in js-yaml (medium 6.8)
- [CVE-2026-59868](https://insights.sbomify.com/CVE-2026-59868/): js-yaml: YAML merge-key chains can force quadratic CPU consumption (medium 5.3)
- [CVE-2026-53550](https://insights.sbomify.com/CVE-2026-53550/): js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases (medium 5.3)
- [CVE-2025-64718](https://insights.sbomify.com/CVE-2025-64718/): js-yaml has prototype pollution in merge (<<) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59869 and fix it if it is affected.

What it is: CVE-2026-59869 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59869 exists.

Affected packages and fixed versions:
- js-yaml (npm): affected from 3.0.0; fixed in 3.15.0
- js-yaml (npm): affected from 3.0.0; fixed in 3.15.0
- js-yaml (npm): affected from 4.0.0; fixed in 4.3.0
- js-yaml (npm): affected from 4.0.0; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59869/ (Markdown: https://insights.sbomify.com/CVE-2026-59869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59869
- OSV: https://osv.dev/vulnerability/CVE-2026-59869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59869/
Summaries are generated and may contain mistakes; the official description above is the record.
