# CVE-2026-59871: node-tar: Process crash via PAX numeric path type confusion

> An attacker can crash the application by providing a tar archive with numeric PAX paths, causing an uncaught TypeError in the node-tar library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLEANSTART-2026-OD75176, CLEANSTART-2026-VH65256, CLEANSTART-2026-XO33315, DEBIAN-CVE-2026-59871, ECHO-6efb-ad73-64a1, GHSA-w8wr-v893-vjvp, MINI-28m8-q5vr-98g7, MINI-2g32-5c6m-8q3x, MINI-2gv9-9pjx-cxqh, MINI-2w48-h86f-3qf3, MINI-58r7-p626-5vx2, MINI-6466-849h-v5pf, MINI-66x9-57q8-g97h, MINI-69c9-c2mw-mrh5, MINI-8pv3-4fr4-pr8q, MINI-8qcg-5m2g-8qc4, MINI-93h9-xjf3-jph5, MINI-98ww-f952-cgf4, MINI-9mm4-fxhf-gpx4, MINI-9rj3-7wcj-3x2m, MINI-c4qv-c9cj-fp8m, MINI-f9vf-jp3j-jh23, MINI-g5px-r9w4-3rh6, MINI-hm6v-x4p3-5p7m, MINI-m8p7-mxg3-rwg2, MINI-p8j7-qfxq-q6jc, MINI-pxfm-7cr7-mhx2, MINI-pxhp-jw3f-7pfp, MINI-qc27-8cgh-2h9m, MINI-rg9x-q3x2-753v, MINI-v54f-vx62-597j, MINI-w5qj-v78h-c2v9, MINI-wf8x-69q9-px6g, MINI-whpj-g8gx-564h, MINI-wmj7-g333-rw67, MINI-x3w4-wp5w-4jr7, MINI-xf82-4wxr-pcvr, ROOT-APP-NPM-CVE-2026-59871, UBUNTU-CVE-2026-59871

## What is CVE-2026-59871?

CVE-2026-59871 is a medium-severity denial of service vulnerability in isaacs node-tar, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-tar is a tar archive manipulation library for Node.js. Prior to 7.5.18, node-tar coerces all-digit PAX path and linkpath values in src/pax.ts to JavaScript numbers, causing downstream path handling such as normalizeWindowsPath(entry.path).split('/') to throw an uncaught TypeError. This issue is fixed in version 7.5.18.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2026-59871?

2 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 7.5.18 |
| `tar` | npm | All versions | 7.5.18 |

Products: Isaacs Tar.

## How do I fix CVE-2026-59871?

Upgrade tar to 7.5.18 or later.

## Is CVE-2026-59871 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59871 exists.

## Other vulnerabilities in isaacs node-tar

- [CVE-2026-59873](https://insights.sbomify.com/CVE-2026-59873/): node-tar: Decompression/parse DoS via unlimited input (critical 9.2)
- [CVE-2026-23950](https://insights.sbomify.com/CVE-2026-23950/): node-tar has Race Condition in Path Reservations via Unicode Ligature Collisions on macOS APFS (high 8.8)
- [CVE-2026-59874](https://insights.sbomify.com/CVE-2026-59874/): node-tar: Negative tar entry size causes infinite loop in archive replace (high 8.7)
- [CVE-2026-31802](https://insights.sbomify.com/CVE-2026-31802/): node-tar Symlink Path Traversal via Drive-Relative Linkpath (high 8.2)
- [CVE-2026-29786](https://insights.sbomify.com/CVE-2026-29786/): node-tar: Hardlink Path Traversal via Drive-Relative Linkpath (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59871 and fix it if it is affected.

What it is: CVE-2026-59871 is a medium-severity denial of service vulnerability in isaacs node-tar, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59871 exists.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 7.5.18
- tar (npm): affected all versions; fixed in 7.5.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59871/ (Markdown: https://insights.sbomify.com/CVE-2026-59871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59871
- OSV: https://osv.dev/vulnerability/CVE-2026-59871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59871/
Summaries are generated and may contain mistakes; the official description above is the record.
