# CVE-2026-59873: node-tar: Decompression/parse DoS via unlimited input

> Attackers can cause denial of service by exhausting disk space and CPU using crafted gzip bombs in the node-tar library.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLEANSTART-2026-HG84395, CLEANSTART-2026-KX94176, CLEANSTART-2026-OH51189, CLSA-2026-1793109968, DEBIAN-CVE-2026-59873, ECHO-c7c8-7028-c3fc, GHSA-23hp-3jrh-7fpw, MINI-2cfh-9fh7-c5x4, MINI-3fxc-76jf-5px8, MINI-4f6w-vqrj-f9v7, MINI-4hgm-528m-327r, MINI-5qmq-733j-gh5p, MINI-6xvg-57c7-x3f9, MINI-754h-j532-wwph, MINI-7578-cw8c-5m6m, MINI-77w6-pj2c-x9xv, MINI-7983-6wg6-rg87, MINI-8hm4-vf33-642c, MINI-8rcw-f3q7-hr93, MINI-93mm-6wp9-f8mp, MINI-c22h-cfhv-mcw8, MINI-cw53-ww98-g9rp, MINI-f7qp-f3j4-wpjc, MINI-f824-6c9q-cqrw, MINI-fm72-jcm4-fqw6, MINI-fx24-gf93-fwp5, MINI-gf48-262h-5fxx, MINI-hhwf-x5v2-77jh, MINI-jjw6-xq44-fjr2, MINI-jpr6-69qw-hf2f, MINI-jvmp-7hrx-frrq, MINI-m3p2-9rfg-pwg6, MINI-m64c-r7cm-wrc7, MINI-p76f-x4c5-rvjw, MINI-pj3w-3jgw-v44w, MINI-q5j2-v3qx-v7g4, MINI-qhvq-fxqf-593f, MINI-r3w6-g3fc-rwr9, MINI-r4p8-jv89-f6xv, MINI-rqq4-x26q-5w98, MINI-v2gh-pq59-qrfx, MINI-v5g9-vcfr-52rr, MINI-vf2m-2xmf-2f9p, MINI-vjqc-f342-2hqv, MINI-vvcv-w788-mq9f, MINI-wp5w-vv76-wqj6, MINI-wqwj-x593-gm68, ROOT-APP-NPM-CVE-2026-59873, UBUNTU-CVE-2026-59873

## What is CVE-2026-59873?

CVE-2026-59873 is a critical denial of service vulnerability in isaacs node-tar, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-tar is a tar archive manipulation library for Node.js. Prior to 7.5.19, node-tar does not enforce hard upper bounds on total decompressed data, entry counts, or decompression ratio in extraction and parsing paths such as src/extract.ts, allowing a small crafted gzip bomb to exhaust disk space and CPU. This issue is fixed in version 7.5.19.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-59873?

2 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 7.5.19 |
| `tar` | npm | All versions | 7.5.19 |

Products: Isaacs Tar.

## How do I fix CVE-2026-59873?

Upgrade tar to 7.5.19 or later.

## Is CVE-2026-59873 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59873 exists.

## Other vulnerabilities in isaacs node-tar

- [CVE-2026-23950](https://insights.sbomify.com/CVE-2026-23950/): node-tar has Race Condition in Path Reservations via Unicode Ligature Collisions on macOS APFS (high 8.8)
- [CVE-2026-59874](https://insights.sbomify.com/CVE-2026-59874/): node-tar: Negative tar entry size causes infinite loop in archive replace (high 8.7)
- [CVE-2026-31802](https://insights.sbomify.com/CVE-2026-31802/): node-tar Symlink Path Traversal via Drive-Relative Linkpath (high 8.2)
- [CVE-2026-29786](https://insights.sbomify.com/CVE-2026-29786/): node-tar: Hardlink Path Traversal via Drive-Relative Linkpath (high 8.2)
- [CVE-2026-24842](https://insights.sbomify.com/CVE-2026-24842/): node-tar Vulnerable to Arbitrary File Creation/Overwrite via Hardlink Path Traversal (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59873 and fix it if it is affected.

What it is: CVE-2026-59873 is a critical denial of service vulnerability in isaacs node-tar, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59873 exists.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 7.5.19
- tar (npm): affected all versions; fixed in 7.5.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59873/ (Markdown: https://insights.sbomify.com/CVE-2026-59873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59873
- OSV: https://osv.dev/vulnerability/CVE-2026-59873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59873/
Summaries are generated and may contain mistakes; the official description above is the record.
