CVE-2026-59878 Denial of service in Apache ActiveMQ

High 7.5 Published Updated

Remote attackers can cause denial of service in Apache ActiveMQ by sending malformed AMQP frames that exhaust NIO thread pools.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59878?

CVE-2026-59878 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All.

A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8.

Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2026-59878?

1 open source package ship an affected version, including activemq. It affects 3 products.

PackageAffectedFixed in
activemq BitnamiAll versions5.19.9, 6.2.8

Products include Apache Activemq, Apache Activemq All, Apache Activemq Amqp.

How do I fix CVE-2026-59878?

Upgrade activemq to a fixed version for your release line: 5.19.9 or 6.2.8.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-59878 being exploited?

There is no known exploitation of CVE-2026-59878 in the wild and no public exploit code.

All Apache Activemq vulnerabilities

Sources

Also known as BIT-activemq-2026-59878, DEBIAN-CVE-2026-59878, GHSA-4mq2-fjvq-8232, MINI-6458-j4vr-qc94, MINI-8v7q-6chx-77m3, MINI-96qm-gfh5-7xrg and 4 more.

Is CVE-2026-59878 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free