{"answers":{"affected":"1 open source package ship an affected version, including activemq. It affects 3 products.","exploited":"There is no known exploitation of CVE-2026-59878 in the wild and no public exploit code.","fix":"Upgrade activemq to a fixed version for your release line: 5.19.9 or 6.2.8.","what":"CVE-2026-59878 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59878 and fix it if it is affected.\n\nWhat it is: CVE-2026-59878 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59878 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activemq (Bitnami): affected all versions; fixed in 5.19.9, 6.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59878/ (Markdown: https://insights.sbomify.com/CVE-2026-59878/index.md)","id":"CVE-2026-59878","markdown":"https://insights.sbomify.com/CVE-2026-59878/index.md","name":"CVE-2026-59878","record":{"aliases":["BIT-activemq-2026-59878","DEBIAN-CVE-2026-59878","GHSA-4mq2-fjvq-8232","MINI-6458-j4vr-qc94","MINI-8v7q-6chx-77m3","MINI-96qm-gfh5-7xrg","MINI-fjq6-6vr8-43wh","MINI-mxm8-946g-7v39","MINI-x778-8vqw-2hfm","UBUNTU-CVE-2026-59878"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Remote attackers can cause denial of service in Apache ActiveMQ by sending malformed AMQP frames that exhaust NIO thread pools.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq","vendor":"apache"},{"product":"activemq_all","vendor":"apache"},{"product":"activemq_amqp","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All.\n\nA remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections.\nThis issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8.\n\nUsers are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Apache ActiveMQ","id":"CVE-2026-59878","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:activemq","products":["apache:activemq"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Immutable.js `List` 32-bit trie overflow → unrecoverable DoS","id":"CVE-2026-59879"},"packages":[{"ecosystem":"Bitnami","fixed":["5.19.9","6.2.8"],"introduced":["0","6.0.0"],"last_affected":[],"package":"activemq","purl":"pkg:bitnami/activemq","source":"BIT-activemq-2026-59878"}],"prev":{"headline":"protobufjs: Denial of Service via infinite loop in .proto option parsing","id":"CVE-2026-59877"},"products":["Apache ActiveMQ","Apache ActiveMQ AMQP","Apache ActiveMQ All"],"published":"2026-07-28","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can cause denial of service in Apache ActiveMQ by sending malformed AMQP frames that exhaust NIO thread pools.","url":"https://insights.sbomify.com/CVE-2026-59878/"}