# CVE-2026-59878: Denial of service in Apache ActiveMQ

> Remote attackers can cause denial of service in Apache ActiveMQ by sending malformed AMQP frames that exhaust NIO thread pools.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** BIT-activemq-2026-59878, DEBIAN-CVE-2026-59878, GHSA-4mq2-fjvq-8232, MINI-6458-j4vr-qc94, MINI-8v7q-6chx-77m3, MINI-96qm-gfh5-7xrg, MINI-fjq6-6vr8-43wh, MINI-mxm8-946g-7v39, MINI-x778-8vqw-2hfm, UBUNTU-CVE-2026-59878

## What is CVE-2026-59878?

CVE-2026-59878 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All.

A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections.
This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8.

Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-59878?

1 open source package ship an affected version, including activemq. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.9, 6.2.8 |

Products: Apache Activemq, Apache Activemq All, Apache Activemq Amqp.

## How do I fix CVE-2026-59878?

Upgrade activemq to a fixed version for your release line: 5.19.9 or 6.2.8.

## Is CVE-2026-59878 being exploited?

There is no known exploitation of CVE-2026-59878 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59878 and fix it if it is affected.

What it is: CVE-2026-59878 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59878 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.9, 6.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59878/ (Markdown: https://insights.sbomify.com/CVE-2026-59878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59878
- OSV: https://osv.dev/vulnerability/CVE-2026-59878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59878/
Summaries are generated and may contain mistakes; the official description above is the record.
