# CVE-2026-59879: Immutable.js `List` 32-bit trie overflow → unrecoverable DoS

> Attackers can cause denial of service via infinite loops or memory exhaustion in Immutable.js List operations using specific large indices.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** CLEANSTART-2026-BB25914, CLEANSTART-2026-PW50490, CLSA-2026-1784682983, CLSA-2026-1784683091, CLSA-2026-1784769532, CLSA-2026-1788775607, CLSA-2026-1790866103, DEBIAN-CVE-2026-59879, ECHO-5345-cd12-bd9a, GHSA-v56q-mh7h-f735, MINI-27pm-8rf7-qgqw, MINI-29v8-g8cc-h688, MINI-64vr-hg44-phx3, MINI-8wp5-wmh6-wf64, MINI-fw5c-7cwj-g29j, MINI-gg32-4fm2-85xv, MINI-vj5g-gwrf-q5vh, MINI-x39j-2q32-rvhm, ROOT-APP-NPM-CVE-2026-59879, UBUNTU-CVE-2026-59879

## What is CVE-2026-59879?

CVE-2026-59879 is a high-severity denial of service vulnerability in immutable-js, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Immutable.js provides many Persistent Immutable data structures. Prior to 4.3.9 and 5.1.8, List#set, List#setSize, List#setIn, List#updateIn, and the functional set, setIn, and updateIn mishandle an index or size in the range 2 ** 30 to 2 ** 31 in setListBounds in src/List.js, causing an empty List to enter an uncatchable infinite loop, a populated List to allocate without bound until process abort, or setSize to silently wrap large values. This issue is fixed in versions 4.3.9 and 5.1.8.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption), CWE-190 (Integer Overflow or Wraparound), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-59879?

6 open source packages ship an affected version, including immutable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `immutable` | npm | All versions | 3.8.4 |
| `immutable` | npm | All versions | 3.8.4 |
| `immutable` | npm | From 4.0.0-rc.1 | 4.3.9 |
| `immutable` | npm | From 4.0.0-rc.1 | 4.3.9 |
| `immutable` | npm | From 5.0.0-beta.1 | 5.1.8 |
| `immutable` | npm | From 5.0.0-beta.1 | 5.1.8 |

Products: Immutable-Js Immutable.

## How do I fix CVE-2026-59879?

Upgrade immutable to a fixed version for your release line: 3.8.4, 4.3.9 or 5.1.8.

## Is CVE-2026-59879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59879 exists.

## Other vulnerabilities in immutable-js

- [CVE-2026-59880](https://insights.sbomify.com/CVE-2026-59880/): Immutable.js: Hash-collision algorithmic complexity denial of service in Immutable.Map/Set (high 8.7)
- [CVE-2026-29063](https://insights.sbomify.com/CVE-2026-29063/): Immutable.js: Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') in immutable (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59879 and fix it if it is affected.

What it is: CVE-2026-59879 is a high-severity denial of service vulnerability in immutable-js, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59879 exists.

Affected packages and fixed versions:
- immutable (npm): affected all versions; fixed in 3.8.4
- immutable (npm): affected all versions; fixed in 3.8.4
- immutable (npm): affected from 4.0.0-rc.1; fixed in 4.3.9
- immutable (npm): affected from 4.0.0-rc.1; fixed in 4.3.9
- immutable (npm): affected from 5.0.0-beta.1; fixed in 5.1.8
- immutable (npm): affected from 5.0.0-beta.1; fixed in 5.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59879/ (Markdown: https://insights.sbomify.com/CVE-2026-59879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59879
- OSV: https://osv.dev/vulnerability/CVE-2026-59879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59879/
Summaries are generated and may contain mistakes; the official description above is the record.
