{"answers":{"affected":"3 open source packages ship an affected version, including pyasn1. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-59884 in the wild and no public exploit code.","fix":"Upgrade pyasn1 to 0.6.4 or later.","what":"CVE-2026-59884 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59884 and fix it if it is affected.\n\nWhat it is: CVE-2026-59884 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59884 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyasn1 (PyPI): affected all versions; fixed in 0.6.4\n- pyasn1 (PyPI): affected all versions; fixed in 0.6.4\n- pyasn1 (PyPI): affected all versions; fixed in 0.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59884/ (Markdown: https://insights.sbomify.com/CVE-2026-59884/index.md)","id":"CVE-2026-59884","markdown":"https://insights.sbomify.com/CVE-2026-59884/index.md","name":"CVE-2026-59884","record":{"aliases":["AZL-92433","BELL-CVE-2026-59884","CLEANSTART-2026-RT57573","DEBIAN-CVE-2026-59884","ECHO-26aa-f245-5297","GHSA-m4p7-r5rc-7g4j","MINI-2cp6-fc8p-9xxw","MINI-2gh8-x8jg-xv7c","MINI-34vc-g2j9-hv87","MINI-428v-68rf-9835","MINI-5f6c-mmc3-j56r","MINI-5w8c-rvhr-q4mm","MINI-66m7-v3hm-v3r7","MINI-75m7-5gjh-p27h","MINI-7cj4-6mwq-xxmx","MINI-8334-8236-cjc4","MINI-cq9q-9pxc-65g3","MINI-fg24-mh62-37wv","MINI-fj7q-rg4f-pcvx","MINI-fxxh-g6f4-w3gw","MINI-gg7f-rq7r-5rc6","MINI-h273-wj7h-h8gf","MINI-hhwj-p34w-9rc4","MINI-hrx2-9wq6-r97w","MINI-j2w6-fc6w-75hh","MINI-j6v3-p5h6-29xg","MINI-mwx2-6fjm-pvrr","MINI-pj6r-3f8r-wc54","MINI-r67x-8h65-xfqw","MINI-r959-gchw-qxp3","MINI-rr9g-4292-4gh9","MINI-rrqr-6pj5-hm6p","MINI-v95v-7j69-9vj5","MINI-w9gh-rqh8-v7qw","PYSEC-2026-3455","ROOT-APP-PYPI-CVE-2026-59884","UBUNTU-CVE-2026-59884"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ASN.1 library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using pyasn1 by sending crafted BER, CER, or DER data that triggers excessive CPU usage and exceptions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pyasn1","vendor":"pyasn1"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs","id":"CVE-2026-59884","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service","id":"CVE-2026-59885"},"packages":[{"ecosystem":"PyPI","fixed":["0.6.4"],"introduced":["0"],"last_affected":[],"package":"pyasn1","purl":null,"source":"GHSA-m4p7-r5rc-7g4j"},{"ecosystem":"PyPI","fixed":["0.6.4"],"introduced":["0"],"last_affected":[],"package":"pyasn1","purl":"pkg:pypi/pyasn1","source":"GHSA-m4p7-r5rc-7g4j"},{"ecosystem":"PyPI","fixed":["0.6.4"],"introduced":["0"],"last_affected":[],"package":"pyasn1","purl":"pkg:pypi/pyasn1","source":"PYSEC-2026-3455"}],"prev":{"headline":"Guzzle: Cookie Disclosure and Injection via IP-Address Domains","id":"CVE-2026-59883"},"products":["pyasn1"],"published":"2026-07-14","related":[{"cvss_score":7.5,"headline":"pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service","id":"CVE-2026-59885","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":7.5,"headline":"pyasn1: Uncontrolled resource consumption when converting decoded REAL values","id":"CVE-2026-59886","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":7.5,"headline":"pyasn1 Vulnerable to Denial of Service via Unbounded Recursion","id":"CVE-2026-30922","kev_date_added":null,"published":"2026-03-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["pyasn1"]},"summary":"Attackers can cause denial of service in applications using pyasn1 by sending crafted BER, CER, or DER data that triggers excessive CPU usage and exceptions.","url":"https://insights.sbomify.com/CVE-2026-59884/"}