# CVE-2026-59884: pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs

> Attackers can cause denial of service in applications using pyasn1 by sending crafted BER, CER, or DER data that triggers excessive CPU usage and exceptions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** AZL-92433, BELL-CVE-2026-59884, CLEANSTART-2026-RT57573, DEBIAN-CVE-2026-59884, ECHO-26aa-f245-5297, GHSA-m4p7-r5rc-7g4j, MINI-2cp6-fc8p-9xxw, MINI-2gh8-x8jg-xv7c, MINI-34vc-g2j9-hv87, MINI-428v-68rf-9835, MINI-5f6c-mmc3-j56r, MINI-5w8c-rvhr-q4mm, MINI-66m7-v3hm-v3r7, MINI-75m7-5gjh-p27h, MINI-7cj4-6mwq-xxmx, MINI-8334-8236-cjc4, MINI-cq9q-9pxc-65g3, MINI-fg24-mh62-37wv, MINI-fj7q-rg4f-pcvx, MINI-fxxh-g6f4-w3gw, MINI-gg7f-rq7r-5rc6, MINI-h273-wj7h-h8gf, MINI-hhwj-p34w-9rc4, MINI-hrx2-9wq6-r97w, MINI-j2w6-fc6w-75hh, MINI-j6v3-p5h6-29xg, MINI-mwx2-6fjm-pvrr, MINI-pj6r-3f8r-wc54, MINI-r67x-8h65-xfqw, MINI-r959-gchw-qxp3, MINI-rr9g-4292-4gh9, MINI-rrqr-6pj5-hm6p, MINI-v95v-7j69-9vj5, MINI-w9gh-rqh8-v7qw, PYSEC-2026-3455, ROOT-APP-PYPI-CVE-2026-59884, UBUNTU-CVE-2026-59884

## What is CVE-2026-59884?

CVE-2026-59884 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59884?

3 open source packages ship an affected version, including pyasn1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyasn1` | PyPI | All versions | 0.6.4 |
| `pyasn1` | PyPI | All versions | 0.6.4 |
| `pyasn1` | PyPI | All versions | 0.6.4 |

Products: Pyasn1 Pyasn1.

## How do I fix CVE-2026-59884?

Upgrade pyasn1 to 0.6.4 or later.

## Is CVE-2026-59884 being exploited?

There is no known exploitation of CVE-2026-59884 in the wild and no public exploit code.

## Other vulnerabilities in pyasn1

- [CVE-2026-59885](https://insights.sbomify.com/CVE-2026-59885/): pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service (high 7.5)
- [CVE-2026-59886](https://insights.sbomify.com/CVE-2026-59886/): pyasn1: Uncontrolled resource consumption when converting decoded REAL values (high 7.5)
- [CVE-2026-30922](https://insights.sbomify.com/CVE-2026-30922/): pyasn1 Vulnerable to Denial of Service via Unbounded Recursion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59884 and fix it if it is affected.

What it is: CVE-2026-59884 is a high-severity denial of service vulnerability in pyasn1, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59884 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4
- pyasn1 (PyPI): affected all versions; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59884/ (Markdown: https://insights.sbomify.com/CVE-2026-59884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59884
- OSV: https://osv.dev/vulnerability/CVE-2026-59884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59884/
Summaries are generated and may contain mistakes; the official description above is the record.
